"You are using a pre-release version of Xcode." but I'm using 8.1 from Mac App Store


(Tj Luoma) #1

When I run brew doctor I get this message:

Warning: You are using a pre-release version of Xcode.
You may encounter build failures or other breakages.
Please create pull-requests instead of filing issues.

But I’m running Xcode right from the Mac App Store:

/Applications/Xcode.app:

	CFBundleShortVersionString:	8.1
	CFBundleVersion:		11544

I am running El Capitan:

ProductName:	Mac OS X
ProductVersion:	10.11.6
BuildVersion:	15G1108

% xcode-select -p
/Applications/Xcode.app/Contents/Developer


(Mike McQuaid) #2

Run brew update and then paste your brew config output here.


(Tj Luoma) #3
% brew update && brew config

Already up-to-date.
HOMEBREW_VERSION: 0.9.9
ORIGIN: https://github.com/Homebrew/brew
HEAD: 06fe347de97975dc01e726f87bf07a56a6fb713e
Last commit: 4 months ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: b163b0d8271500557664422d6fdc3054d0ff7d31
Core tap last commit: 4 months ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_REPOSITORY: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
HOMEBREW_BOTTLE_DOMAIN: https://homebrew.bintray.com
CPU: quad-core 64-bit broadwell
Homebrew Ruby: 2.0.0-p648
Clang: 8.0 build 800
Git: 2.9.2 => /usr/local/bin/git
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby
Java: N/A
OS X: 10.11.6-x86_64
Xcode: 8.1
CLT: 7.3.1.0.1.1461711523
X11: 2.7.11 => /opt/X11


(Mike McQuaid) #4

Run cd "$(brew --repo)" && git fetch && git reset --hard origin/master && brew update --force and you should be good again.


(Tj Luoma) #5

Thanks! That solved the problem!


(Allan Kinnaird) #6

Thanks Mike! I’d been puzzled since I noticed during the autumn that brew update wasn’t producing any activity, and I was getting the “pre-release Xcode” warning from brew upgrade. I thought it was because I’d let my versions of Xcode and the Command Line Tools get out of step, so I tried unsuccessfully to sort that, but otherwise let it sit until the full release of Xcode 8.2. Then it became obvious something else was wrong and your advice appeared at just the right moment.