Yarn depends on node, but I have non-homebrew node


(Kornel) #1

I’ve been using Node as installed from the official pkg. I don’t have any particular reason for using the pkg, but I’m not switching to homebrew’s installation in case it’d create some conflicts/duplicates.

However, Yarn now suggests using brew install yarn, and that pulls in homebrew’s node.

Is there a way to tell Homebrew that I have node already?

What will happen to my pkg-installed Node if I install Node from Homebrew?


(Mike McQuaid) #2

We do not support using an external Node in this way, sorry. You may want to install Yarn outside of Homebrew instead.