Xcode 8.3.3 too outdated?


(Jkili) #1

When running brew upgrade xxxx, I am getting Error: Your Xcode (8.3.3) is too outdated. Please update to Xcode 9.0 (or delete it). Xcode can be updated from https://developer.apple.com/download/more/.

This seems a harsh position since 8.3.3 is the current release and 9.0 is only in BETA (and not stable yet).

Is there someway to ignore this warning? The upgrade command wont work because of it.


(Mike McQuaid) #2

You’re using a beta OS which means you need a beta Xcode.


(Jkili) #3

I have both 8.3.3 and 9.0 installed on MacOS High Sierra. How can I stop this error so I can update the other packages?


(Mike McQuaid) #4

Either uninstall or move/rename Xcode 8.3.3 for now. Please also file an issue; you should be allowed to have both installed side-by-side and that we don’t allow this is a bug on our end. Thanks!


(Mike McQuaid) #5

Ah, I see you already did! Thanks.


(Mike McQuaid) #6

Actually: you didn’t so please do :smiley:


(Jkili) #7

OK, no worries. Will do. Thanks


(Richard) #8

@jkill you should be able to use

sudo xcode-select --switch //Xcode-beta.app


(Louispar) #9

Hi there, just want to Post a possible Solution, which helped me: https://stackoverflow.com/a/40297388