Xcode 8.0 is outdated?


(Jc Leyba) #1

I can’t install any homebrew formula because it tells me:

“Error: Your Xcode (8.0) is outdated.
Please update to Xcode 8.1 (or delete it).
Xcode can be updated from the App Store.”

I’ve recently upgraded to Sierra and Xcode 8.0. I figure this can’t be true and something else must have gone wrong. Any help would be appreciated - and apologies if this is a simple thing.


(loyaltyarm) #2

Also getting this on Sierra.

According to this line this would be on purpose, but should be fixable by setting the CI env variable. From this post, it would seem that you could set that CI env variable with export TRAVIS=1


(Mike McQuaid) #3

I figure this can’t be true

It is true. Update your Xcode.


(loyaltyarm) #4

I think my comment was incorrect, if you want to set the CI ENV you can use export CI=1


(Tobias Sturm) #5

Had the same issue on OS X Sierra and Homebrew 1.0.9.
I removed XCode from my application folder via finder, which fixed it.


(Zajako) #6

This worked for me as well, thanks!