Why does Homebrew install Postgres 10.5?


(Yngve Høiseth) #1

According to Postgres’ release history, the latest version is 11.1. On the 10.x branch, it’s 10.6.

I’m curious: Why does Homebrew install version 10.5?

I’m asking because I’d like to use the same version as we’re using in production (which is currently 10.6, but hopefully 11.1 soon). I haven’t been able to find any relevant information on GitHub or similar.

I’d like to make clear that I deeply appreciate the work that’s put into Homebrew, and that I in no way feel that anyone owes me an answer to my question.


(Sean Molenaar) #2

There’s 2 pull requests open to update it but none have been merged yet due to CI failures.



(Yngve Høiseth) #3

Ah, thanks. I should have checked for pull requests in addition to issues. Lesson learned :slight_smile: