"Warning: Your Xcode (9.4.1) is outdated."


(tuexss) #1

Why does homebrew keep posting factually wrong warnings like this? 9.4.1 is latest stable release and definitely not outdated. Also “Please update to Xcode 10.0” is misleading, as Xcode 10.0 hasn’t been released yet, only beta versions.


(Sean Molenaar) #2

What macOS version are you on? Because I don’t get these warnings.


(tuexss) #3

I’m on Mojave 10.14 Beta


(Mike McQuaid) #4

You need Xcode 10 on Mojave.


(tuexss) #5

But XCode 10 doesn’t exist yet. Only betas.


(Sean Molenaar) #6

Neither does macOS mojave