Warning: your HOMEBREW_PREFIX is set to /usr/local but HOMEBREW_CELLAR is set to /usr/local/Cellar. Your current HOMEBREW_CELLAR


(Willrun4fun) #1

Warning: your HOMEBREW_PREFIX is set to /usr/local but HOMEBREW_CELLAR is set
to /usr/local/Cellar. Your current HOMEBREW_CELLAR location will stop
you being able to use all the binary packages (bottles) Homebrew provides. We
recommend you move your HOMEBREW_CELLAR to /usr/local/Cellar which will get you
access to all bottles."

What do I need to do here?


(Mike McQuaid) #2

You can ignore it; the message will go away shortly.


#3

I’m also getting this and it hasn’t gone away. Can someone reply as to the cause of this message and why it will “go away” (if it will)? What are the implications of doing nothing until it “goes away”?
Thanks.


(Mike McQuaid) #4

You are likely not getting the identical message (yours will likely mention /usr/local/Homebrew somewhere). Can you paste yours?


(Ahmed Charles) #5

I’m seeing this message, though in my case, I actually did place the Cellar in a non-default location. But I also run with the env variable that always builds from source, so the fact that bottles are broken is irrelevant. Is it possible to have this warning inspect whether the bottles are being used or not?


(Ahmed Charles) #6

Oh, and it would be nice if it told you how to move the Cellar, rather than just that you should move it.


(Mike McQuaid) #7

@ahmedcharles We don’t support building everything from source as a configuration as it adds to our support burden.


(Justin Purnell) #8

I am getting the HOMEBREW_PREFIX is /usr/local but HOMEBREW_CELLAR is set to /usr/local//Homebrew/Cellar version of the message…should we still expect that to go away soon? I tried modifying my .bash_profile to correct this, but it doesn’t seem to be taking.
Thanks!


(Juliusbachnick) #9

The Issue still persists and hence I am unable to start my postgresql93 as a service. :confused:


(Mike McQuaid) #10

@juliusbachnick Your issue is unrelated and you’re likely not getting an identical message.


(Juliusbachnick) #11

It is related:

brew services start versions/postgresql93

gives me

Warning: your HOMEBREW_PREFIX is set to /usr/local but HOMEBREW_CELLAR is set
to /usr/local/Homebrew/Cellar. Your current HOMEBREW_CELLAR location will stop
you being able to use all the binary packages (bottles) Homebrew provides. We
recommend you move your HOMEBREW_CELLAR to /usr/local/Cellar which will get you
access to all bottles."
Error: No available formula with the name "versions/postgresql93"

Setting HOMEBREW_CELLAR to a different path in my .zshrc seems to be ignored.


(Mike McQuaid) #12

@juliusbachnick That’s not related. You’re specifying a formula that doesn’t exist (it should be homebrew/versions/postgresql93. You should run brew bundle dump, rm -rf /usr/local/Homebrew/Cellar, brew bundle to uninstall and reinstall your packages in a way that lets you use binaries.


(Vinamra Misra) #13

I am also getting the same message…
In the config is see HOMEBREW_PREFIX: /usr/local and HOMEBREW_CELLAR: /usr/local/homebrew/Cellar
Do we really need to fix this? My applications in homebrew/Cellar are working fine.


(Mike McQuaid) #14

@vinamra0991 You can ignore it but you’ll avoid binary packages so things will be slower and less reliable.


(Mariotti) #15

Not sure… It means there is no solution?
This is not going away, it is simply 2/3 months I still get this message.
Most of the packages/progs/etc are indeed still working, but of course I cannot be sure about.

What about a symbolic link? Would that temporarily solve at least the error message?


(Mike McQuaid) #16

@mariotti The solution was detailed above:

brew bundle dump
rm -rf /usr/local/Homebrew/Cellar
brew bundle