Warning: Unknown support status

I’ve recently been getting this warning recently when running brew doctor: Warning: Unknown support status

Any ideas what this warning means? Would love to get to the root cause!

Can you post the output of brew config and brew doctor?

brew config
HOMEBREW_VERSION: 2.4.8-105-g1b7c498
ORIGIN: https://github.com/Homebrew/brew
HEAD: 1b7c498d354a098572cfcf06e18d54ff25c4c0b8
Last commit: 5 hours ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: c1598f7e9cc8978a0790c8a5fa6975c4b202370e
Core tap last commit: 2 hours ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_DISPLAY: /private/tmp/com.apple.launchd.CTVHS3VU1l/org.macosforge.xquartz:0
HOMEBREW_EDITOR: /Users/kwhite/bin/mate -w
HOMEBREW_MAKE_JOBS: 12
CPU: dodeca-core 64-bit kabylake
Homebrew Ruby: 2.6.3 => /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/ruby
Clang: 11.0 build 1103
Git: 2.27.0 => /usr/local/bin/git
Curl: 7.64.1 => /usr/bin/curl
Java: 14.0.2, 14.0.1, 1.8.0_60, 1.7.0_51, 1.6.0_65-b14-462
macOS: 10.15.6-x86_64
CLT: 1103.0.32.62
Xcode: 11.6
XQuartz: 2.7.11 => /opt/X11

brew doctor
Please note that these warnings are just used to help the Homebrew maintainers
with debugging if you file an issue. If everything you use Homebrew for is
working fine: please don’t worry or file an issue; just ignore this. Thanks!

Warning: Unknown support status

I was having this issue as well.

The error message is due to Homebrew Cask Quarantine checks failing when running swift /usr/local/Homebrew/Library/Homebrew/cask/utils/quarantine.swift

Apparently, Apple distributed a broken libxml2 in their command line tools, so I just needed to completely remove and reinstall the CLT.

Steps to remove and reinstall CLT:

  1. Run xcode-select --print-path to find the CLT path (for me, /Library/Developer/CommandLineTools
  2. Remove that folder (maybe make a backup first)
  3. Run xcode-select --install

I’m not sure that will work in your case, though, as you have Xcode installed (CLT comes with Xcode automatically and I don’t know if you can update it separately). Is there any chance there’s an update available for Xcode or the CLT? I’d look in both the App Store and Software Update (maybe take a look at this link)

If none of the above work, I’d suggest posting the output to swift /usr/local/Homebrew/Library/Homebrew/cask/utils/quarantine.swift and see if there’s anything there that gives a hint.

4 Likes

This worked for me.
Thanks,

1 Like

Thanks @Rylan12 There wasn’t an update for Xcode, however reinstalling the CLT from scratch worked fine.

1 Like