Unable to install - Illegal variable name


(Warlock777) #21

I didn’t notice the bash/zsh requirement on the installation page until just now… :blush:

Thanks again.


(Mike McQuaid) #22

Heh, wow, impressive migration path there. Glad you’re sorted now.


(Nklmthr) #23

Thankyou guys. This was really helpful…


(Lew18) #24

Yes, very helpful.

on https://brew.sh I don’t see a requirement for bash or zsh…is using these just obvious to most people these days? Thanks.


(Jamesdipalma) #25

In case anyone else has similar problems. Oddly, my shell (tcsh), confusingly says it is bash:

% echo $SHELL
/bin/bash

homebrew did install using this sequence of commands::
% curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install > homebrew_install
% ruby homebrew_install

Also ran from zsh.


(Marlon62) #26

Thanks guys this was very helpful!

I too had my default shell set to tcsh not bash. Didn’t realize it though…


(Franklin Yu) #27

IIRC Bash is the default shell for macOS. Whenever you change it you need to know the consequence. The installer command is obviously Bash.


(Lew18) #29

Requirement for bash or zsh is listed on https://docs.brew.sh/Installation, which is the page clicking on options takes you to.

For those of us who have had Macs for decades, default shell was originally tcsh
see http://www.peachpit.com/articles/article.aspx?p=31442&seqNum=2

And that doesn’t get changed when migrate from one OS to the next.