Unable to install Homebrew in macOS High Sierra 10.13.5


(Deivigan87) #1

I am trying to install homebrew using the command /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Please some one help me in resolving this issue as i need it very urgently

xxxxxxxx:~ rajedei$ /usr/bin/ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”
==> This script will install:
/usr/local/bin/brew
/usr/local/share/doc/homebrew
/usr/local/share/man/man1/brew.1
/usr/local/share/zsh/site-functions/_brew
/usr/local/etc/bash_completion.d/brew
/usr/local/Homebrew

Press RETURN to continue or any other key to abort
==> Downloading and installing Homebrew…
remote: Counting objects: 102881, done.
remote: Compressing objects: 100% (16/16), done.
remote: Total 102881 (delta 3), reused 6 (delta 0), pack-reused 102865
Receiving objects: 100% (102881/102881), 23.42 MiB | 180.00 KiB/s, done.
Resolving deltas: 100% (74971/74971), done.
From https://github.com/Homebrew/brew

  • [new branch] master -> origin/master
  • [new tag] 0.1 -> 0.1
  • [new tag] 0.2 -> 0.2
  • [new tag] 0.3 -> 0.3
  • [new tag] 0.4 -> 0.4
  • [new tag] 0.5 -> 0.5
  • [new tag] 0.6 -> 0.6
  • [new tag] 0.7 -> 0.7
  • [new tag] 0.7.1 -> 0.7.1
  • [new tag] 0.8 -> 0.8
  • [new tag] 0.8.1 -> 0.8.1
  • [new tag] 0.9 -> 0.9
  • [new tag] 0.9.1 -> 0.9.1
  • [new tag] 0.9.2 -> 0.9.2
  • [new tag] 0.9.3 -> 0.9.3
  • [new tag] 0.9.4 -> 0.9.4
  • [new tag] 0.9.5 -> 0.9.5
  • [new tag] 0.9.8 -> 0.9.8
  • [new tag] 0.9.9 -> 0.9.9
  • [new tag] 1.0.0 -> 1.0.0
  • [new tag] 1.0.1 -> 1.0.1
  • [new tag] 1.0.2 -> 1.0.2
  • [new tag] 1.0.3 -> 1.0.3
  • [new tag] 1.0.4 -> 1.0.4
  • [new tag] 1.0.5 -> 1.0.5
  • [new tag] 1.0.6 -> 1.0.6
  • [new tag] 1.0.7 -> 1.0.7
  • [new tag] 1.0.8 -> 1.0.8
  • [new tag] 1.0.9 -> 1.0.9
  • [new tag] 1.1.0 -> 1.1.0
  • [new tag] 1.1.1 -> 1.1.1
  • [new tag] 1.1.10 -> 1.1.10
  • [new tag] 1.1.11 -> 1.1.11
  • [new tag] 1.1.12 -> 1.1.12
  • [new tag] 1.1.13 -> 1.1.13
  • [new tag] 1.1.2 -> 1.1.2
  • [new tag] 1.1.3 -> 1.1.3
  • [new tag] 1.1.4 -> 1.1.4
  • [new tag] 1.1.5 -> 1.1.5
  • [new tag] 1.1.6 -> 1.1.6
  • [new tag] 1.1.7 -> 1.1.7
  • [new tag] 1.1.8 -> 1.1.8
  • [new tag] 1.1.9 -> 1.1.9
  • [new tag] 1.2.0 -> 1.2.0
  • [new tag] 1.2.1 -> 1.2.1
  • [new tag] 1.2.2 -> 1.2.2
  • [new tag] 1.2.3 -> 1.2.3
  • [new tag] 1.2.4 -> 1.2.4
  • [new tag] 1.2.5 -> 1.2.5
  • [new tag] 1.2.6 -> 1.2.6
  • [new tag] 1.3.0 -> 1.3.0
  • [new tag] 1.3.1 -> 1.3.1
  • [new tag] 1.3.2 -> 1.3.2
  • [new tag] 1.3.3 -> 1.3.3
  • [new tag] 1.3.4 -> 1.3.4
  • [new tag] 1.3.5 -> 1.3.5
  • [new tag] 1.3.6 -> 1.3.6
  • [new tag] 1.3.7 -> 1.3.7
  • [new tag] 1.3.8 -> 1.3.8
  • [new tag] 1.3.9 -> 1.3.9
  • [new tag] 1.4.0 -> 1.4.0
  • [new tag] 1.4.1 -> 1.4.1
  • [new tag] 1.4.2 -> 1.4.2
  • [new tag] 1.4.3 -> 1.4.3
  • [new tag] 1.5.0 -> 1.5.0
  • [new tag] 1.5.1 -> 1.5.1
  • [new tag] 1.5.10 -> 1.5.10
  • [new tag] 1.5.11 -> 1.5.11
  • [new tag] 1.5.12 -> 1.5.12
  • [new tag] 1.5.13 -> 1.5.13
  • [new tag] 1.5.14 -> 1.5.14
  • [new tag] 1.5.2 -> 1.5.2
  • [new tag] 1.5.3 -> 1.5.3
  • [new tag] 1.5.4 -> 1.5.4
  • [new tag] 1.5.5 -> 1.5.5
  • [new tag] 1.5.6 -> 1.5.6
  • [new tag] 1.5.7 -> 1.5.7
  • [new tag] 1.5.8 -> 1.5.8
  • [new tag] 1.5.9 -> 1.5.9
  • [new tag] 1.6.0 -> 1.6.0
  • [new tag] 1.6.1 -> 1.6.1
  • [new tag] 1.6.2 -> 1.6.2
  • [new tag] 1.6.3 -> 1.6.3
  • [new tag] 1.6.4 -> 1.6.4
  • [new tag] 1.6.5 -> 1.6.5
  • [new tag] 1.6.6 -> 1.6.6
  • [new tag] 1.6.7 -> 1.6.7
  • [new tag] 1.6.8 -> 1.6.8
    HEAD is now at c5974840c Merge pull request #4333 from Homebrew/dependabot/bundler/Library/Homebrew/test/rspec-retry-0.6.1
    /usr/local/Homebrew/Library/Homebrew/PATH.rb:71:in split': invalid byte sequence in UTF-8 (ArgumentError) from /usr/local/Homebrew/Library/Homebrew/PATH.rb:71:inblock in parse’
    from /usr/local/Homebrew/Library/Homebrew/PATH.rb:71:in each' from /usr/local/Homebrew/Library/Homebrew/PATH.rb:71:inflat_map’
    from /usr/local/Homebrew/Library/Homebrew/PATH.rb:71:in parse' from /usr/local/Homebrew/Library/Homebrew/PATH.rb:8:ininitialize’
    from /usr/local/Homebrew/Library/Homebrew/global.rb:62:in new' from /usr/local/Homebrew/Library/Homebrew/global.rb:62:in<top (required)>’
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in require' from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:inrequire’
    from /usr/local/Homebrew/Library/Homebrew/brew.rb:27:in `’
    Failed during: /usr/local/bin/brew update --force
    xxxxxxxxxx:~ rajedei$

(Sean Molenaar) #2

what does echo $PATH return for you?


(Deivigan87) #3

It gave some info on JAVA Home Path & Maven Path.


(Deivigan87) #4

I used /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/uninstall)"
and then tried installing using /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" and it has been installed successfully


(Sean Molenaar) #5

Good to see it’s fixed!