Subversion 1.8 fails to build

Hi,

When I’ve installed subversion 1.8 using brew install subversion@1.8 command, then attempt to run /usr/local/Cellar/subversion@1.8/1.8.19_1/bin/svn --version command resulted in this error:

dyld: Library not loaded: /usr/local/opt/libmagic/lib/libmagic.1.dylib
  Referenced from: /usr/local/bin/svn
  Reason: image not found
Abort trap: 6

To fix that I had to run brew install libmagic command. I guess that should be dependency of https://formulae.brew.sh/formula/subversion@1.8 formulae.

Thank you.

Could you create an issue in the main repo? https://github.com/Homebrew/homebrew-core/issues/new/choose will get you to the page you need to do that.

Created an issue: https://github.com/Homebrew/homebrew-core/issues/44226. Thank you.

1 Like