SPAdes multithreading not working

Hi!

I tried installing SPAdes via Homebrew (https://formulae.brew.sh/formula/spades#default) yesterday, and was surprised by the long time the genome assembly took (about 2,5 hours instead of 20-30 minutes). Turned out SPAdes used only 1 thread instead of 16.

0:00:00.000     5M / 5M    INFO    General                 (main.cpp                  :  78)   Maximum # of threads to use (adjusted due to OMP capabilities): 1

After a long time trying to set up a correct number of OpenMP threads manually, with no luck, I contacted the SPAdes support team and was recommended to download it from their original site (https://cab.spbu.ru/software/spades/). And it worked just fine, using all the 16 threads in my CPU without any options.

So I just wanted you to know, that the SPAdes formulae is somehow broken with multithreading disabled. I hope this can be solved, as using Homebrew turned out to be very convenient=)

Please let me know, if I can provide additional info, that can be useful to solve this issue.

@D-masik Thanks for the pointer. Which type of CPU do you use, and which OS and OS version?

It’s a 2019 15-inch Macbook Pro, with 2,3 GHz Intel Core i9 (9880H), with Mac OS 10.14.6.