(solved) /bin/gzip: 10: Syntax error: "(" unexpected

/bin/gzip: 10: Syntax error: “(” unexpected

That’s the error I get when doing any sort of install/upgrade with Homebrew on WSL (Windows Subsystem for Linux), now.

So I completely uninstalled WSL, Re-installed it, and tried to install Brew. Same error. It seems gzip doesn’t like a missing parenthesis?

Any ideas? Thanks!

(Ubuntu 19.10 on WSL under Windows 10 1909.)

Something is wrong with your gzip command. You’ll need to figure out what’s wrong with your WSL installation. What does file /bin/gzip say?

Thanks for the reply!

Output of “file /bin/gzip”:

/bin/gzip: ELF 64-bit LSB pie executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, BuildID[sha1]=bc0f5994544c2a469d04c91
4bf4bf44b4ded6040, for GNU/Linux 3.2.0, stripped

Edit: I’m pretty sure that the problem lies with the upgrade from Ubuntu 19.04 to 19.10, as everything was working just fine under 19.04. Since 19.04 will be EOL soon, I just went back to 18.04 LTS. It’s only WSL. LOL. Brew works just fine under 18.04 LTS.

Thanks!