SHA256 mismatch on install protobuf

Just attempted to install protobuf, but got the followings:-
Error: SHA256 mismatch
Expected: 2a25c2b71c707c5552ec9afdfb22532a93a339e1ca5d38f163fe4107af08c54c
Actual: a839d3f1519ff9d68ab908de5a0f269650ef1fc501c10f6eefd4cae51d29b86f

Edit protobuf ?

You seem to have an issue where it downloaded an incorrect file, for me it downloads without issues. Try running brew update and trying again to see if the issue persists. If it does it could be a network issue but it could even be a Man in the Middle attack.

Thanks ! @SMillerDev
I did try brew update, didn’t work
fatal: cannot create directory at ‘Library/Homebrew/cask/cmd’: Permission denied
Cannot rebase: You have unstaged changes.
Please commit or stash them.

and
Updating Homebrew…
error: insufficient permission for adding an object to repository database .git/objects
Cannot save the current index state
Error: Could not ‘git stash’ in /usr/local/Homebrew!

Then reinstall brew, -bash
I was trying to install protobuf … seems hitting Permission denied issues and the same SHA256 mismatch problem.

I could do a brew edit of protobuf if necessary ?

1 Like

somehow your homebrew install seems to be broken. First off you can run sudo chown -R $(whoami) /usr/local/* to restore permission for the directories to your user. After this you should be able to run brew update to restore all repositories to their latest versions.

Thanks !
Brew Update done with the following:-
Updated Homebrew from 881fdcd25 to f527f03fb.
Warning: Aleth (formerly cpp-ethereum) has been removed from Homebrew. Please install binary releases from https://github.com/ethereum/aleth/releases.
Updated 3 taps (homebrew/core, paritytech/paritytech and ethereum/ethereum).

with new and renamed formulae
and deleted formulae, to include:
opsenssl and python3

Seems I still have the old python 2.7.16 as well as python3 3.8.2

So I carried brew upgrade python AND brew upgrade which all wen fine.

The aim is to re do a cmake …
Which failed with following:

cmake …
– Compiler: AppleClang 10.0.0.10001044
– WARNING: ccache is enabled but wasn’t found on your system - strongly advise installing ccache for reduced build times
– Info: [LTO] Link-time optimisation is supported
– Info: [LTO] Link-time optimisation enabled
– OpenSSL version 1.1.1b
– OpenSSL include /Users/Kraken/fetchai/ledger/build/vendor/openssl/include
CMake Error at vendor/pybind11/tools/FindPythonLibsNew.cmake:95 (message):
Python config failure:

Call Stack (most recent call first):
vendor/pybind11/tools/pybind11Tools.cmake:16 (find_package)
vendor/pybind11/CMakeLists.txt:33 (include)

– Configuring incomplete, errors occurred!

Look like the required python is wrong …