Python and PEP 394

(Mike McQuaid) #1

We have heard your feedback on Python 3 and tomorrow will be making brew install python and brew install python@2 PEP 394 compliant: …. We will not change this again until PEP 394 has changed. Sorry for the pain; we’ve tried our best :heart:

Thank you to everyone who helped with this effort and provided constructive, polite and actionable feedback. No thanks to those who have used this as an excuse to abuse the entirely volunteer run project and maintainers.

(Mike McQuaid) #2

Why is python@2 keg-only?
Duplicate Formulae: "python" & "python3"
How to install `python3` without making the `python` symlink?
Brew install python3 fails
Virtualenv uses nonexistent python interpreter
After changes to Python formulae, 3rd party applications no longer work
(Mike McQuaid) #4