Problem with line tools too outdated


(Eliza Hu) #1

I install the iTerm2 3.0.15(the current stable version) and Homebrew, but when I run “brew install XXX”, There will be a problem: “Error: Your Command Line Tools are too outdated.”
Please help me restore it,Thanks!


(Joshua McKinney) #2

The command line tools this message refers to are the Apple xcode command line tools and can be installed by running: xcode-select --install
To check the installed version, try: xcode-select -v
If you’ve definitely installed this correctly, try checking that there are no outstanding software updates in the App Store app.

For diagnosis, please provide your macOs version and any other info you might have that could be useful.


(Eliza Hu) #3

It works! Thank you so much~~