Pidgin: Missing Perl development headers on High Sierra

Hi,

I tried to get https://github.com/Homebrew/homebrew-core/pull/42864 merged, but the build bot complained about not being able to build Pidgin for High Sierra. I now managed to set up a High Sierra VM and can reproduce the issue:

==> ./configure --prefix=/usr/local/Cellar/pidgin/2.13.0_3 --disable-avahi --disable-dbus --disable-doxygen --disable-gevolution --disable-gstreamer --disable-gstreamer-interfaces --disable-gtkspell --disable-meanwhile --disable-vv --enabl
Last 15 lines from /Users/kgraefe/Library/Logs/Homebrew/pidgin/01.configure:
Building without D-Bus support
checking for Python compile flags... ok
checking for perl... /usr/bin/perl
checking for Perl compile flags... ok
checking for libperl... checking for perl_run... no
checking EXTERN.h usability... yes
checking EXTERN.h presence... no
configure: WARNING: EXTERN.h: accepted by the compiler, rejected by the preprocessor!
configure: WARNING: EXTERN.h: proceeding with the compiler's result
checking for EXTERN.h... yes
checking for perl.h... yes
configure: error:
Perl development headers not found.
Use --disable-perl if you do not need Perl scripting support.


READ THIS: https://docs.brew.sh/Troubleshooting

Now afaik Pidgin’s Perl support is only used to for Perl plugins. As it’s hard to set up on Windows, there are some Perl plugins but not too many. So we could either disable Perl support completely or add Perl as a dependency. What would be Homebrew’s preference here?

Are there other formulae that had problems with Perl on High Sierra?

Since optionals are removed from core, you have only two options:

  1. Set perl as build dependency and build pidgin with it
    or
  2. Not use perl at all and disable it with configuration flag

Thank you for your response. I found a work-around that has been merged while I was offline for a few days: https://github.com/Homebrew/homebrew-core/pull/43067