如何安装php71-event扩展,我的homebrew是1.5版本


(Serious Cl) #1

昨天更新后发现扩展都没有了,这让我很苦恼,现在我完全没办法工作。


(Jacob Ledbetter) #2

对由此造成的不便,我深表歉意。 PHP及其扩展已被弃用并移至核心。 阅读这篇文章了解更多信息。(https://brew.sh/2018/04/09/homebrew-1.6.0/)


(Serious Cl) #3

有没有办法链接到之前的版本库呢,我想使用之前的


(Jacob Ledbetter) #4

正如我所说的,Homebrew-core现在是PHP的主机,所以只需brew search php并找到你想要的版本即可。 如果这不起作用,请尝试brew update并查看是否修复它。


(Shi Xinyu) #5

请问现在添加 PHP 扩展是否只能通过 pear 的方式来添加?brew 不再支持了?


(Jacob Ledbetter) #6

梨? 就我所知,Php将通过brew进行提供。


(Shi Xinyu) #7

我是说 PHP 扩展的安装,并不是指 PHP
I means php extension install ways, rather than php install


(Yue Ban) #8

你找到其他php的tap了么,以前的homebrew/php已经过时(清空)了,core里面就只有几个版本的php。我升级之前通过brew安装的php的扩展倒是还留在电脑里面,手动关联一下应该还能动。


(Shi Xinyu) #9

我这是台新电脑,之前没有安装过 PHP 扩展:joy: