Node & Python3 stops immediately after launch

(Niels Olof Bouvin) #1

I have run into a problem that I would like some suggestions on how to fix: brew installed node.js and python3 stops immediately after launch on the command line:

$ node

[1]+  Stopped                 node
$ fg
node
Welcome to Node.js v12.1.0.
Type ".help" for more information.
>  [ctrl-D]
$

Python3 behaves in the same manner. I have tried making a complete uninstall of, in order, node, python3, and brew to no avail. I have created a new user to see if the problem persisted (it did).

To add to the perversity: on my MBP, I see the same behaviour, but only on the first launch of node or python3. Subsequent launches stay in the foreground as they should.

Any suggestions?

Running macOS 10.14.4 and brew 2.1.2.

(Sean Molenaar) #2

This looks like a shell config issue to me. Do other apps go to the background too?

(Niels Olof Bouvin) #3

I have only seen it with these two, e.g., standard macOS python does not behave in this manner.

I created a new user account to see whether a stock shell setup would also exhibit this behaviour, and it did.

However, on a hunch I disabled the company issued McAfee AV, and that, strangely enough, seems to have worked.