New installs requiring Xcode manually installed from App Store

There is a closed post without detail but I wanted to provide more background.

when running some of the scripts for homebrew install it used to just automatically get Command Line Tools but now in Mojave its saying this

“Can’t install the software because it is not currently available from the Software Update server.”

Even after you try to install from the GUI.

1 Like

I’m not sure if this is the same thing but this change in OS::Mac bumps latest_sdk_version to 10.15 which causes OS::Mac::Xcode to fail it’s own latest_sdk_version? check, which causes needs_clt_installed? to prompt the user to run xcode-select --install even though I the 10.15 sdk does not seem to be generally available.

1 Like

@tvon What command are you running and what’s the output of it, brew config and brew doctor? Thanks!

1 Like

I am also having the same problem. The code I’m running is:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

After I press install and agree with the terms, an error pops up stating:
“Can’t install the software because it is not currently available from the Software Update server.”

I am fairly new to programming so I may be skipping a step

1 Like

I’ve just downloaded the xocde dmg and installing that first via cli bash script, cause fuck apple and their constantly making things more difficult. . .

Seriously. . .

1 Like

I’ve gotten past it by logging into my Apple Developer account and manually downloading/installing the command line tools.

I can tell you what I was running and saw (based on scrollback) was:

[tvon:~] % brew upgrade azure-cli neovim terraform
Updating Homebrew...
==> Auto-updated Homebrew!
Updated 1 tap (homebrew/core).
==> Updated Formulae
fn                            gnunet                        istioctl                      joplin

Error: azure-cli 2.0.66 already installed
==> Upgrading 2 outdated packages:
neovim 0.3.5 -> 0.3.7, terraform 0.12.0 -> 0.12.1
==> Upgrading neovim
Error: Xcode alone is not sufficient on Mojave.
Install the Command Line Tools:
  xcode-select --install

I already had xcode installed. I tried uninstall/reinstall to no avail.

My brew doctor output warned of not using /usr/local (I never have) and gave the xcode-select --install error (I’d paste but that is no longer in scrollback).

Probably of no use now but for kicks here is my current brew config:

[tvon:~] 1 % brew config
HOMEBREW_VERSION: 2.1.4-57-g80230ec
ORIGIN: https://github.com/Homebrew/brew
HEAD: 80230eccf7c0c7371d622cddf191e3777eb40a0a
Last commit: 20 hours ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: c58dce188e274656041f0dd72aca59a8a968248d
Core tap last commit: 17 hours ago
HOMEBREW_PREFIX: /opt/homebrew
HOMEBREW_CELLAR: /opt/homebrew/Cellar
HOMEBREW_REPOSITORY: /opt/homebrew
HOMEBREW_DEV_CMD_RUN: 1
HOMEBREW_GITHUB_API_TOKEN: set
HOMEBREW_VISUAL: nvim
CPU: octa-core 64-bit haswell
Homebrew Ruby: 2.3.7 => /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby
Clang: 10.0 build 1001
Git: 2.21.0 => /opt/homebrew/bin/git
Curl: 7.54.0 => /usr/bin/curl
Java: 1.8.0_74
macOS: 10.14.5-x86_64
CLT: 10.2.1.0.1.1554506761
Xcode: 10.2.1
CLT headers: 10.2.1.0.1.1554506761
XQuartz: 2.7.11 => /opt/X11
1 Like

This is what I’ve done.

Downloaded the Command Line Tools for xCode 10.2 dmg, installed that with

hdiutil attach /Path to Command_Line_Tools_macOS_10.14_for_Xcode_10.2.dmg

sudo installer -pkg /Volumes/Command\ Line\ Developer\ Tools/Command\ Line\ Tools\ \{macOS\ Mojave\ version\ 10.14\).pkg -target "/"

hdiutil detach /Volume/Command*

Continue brew install via shell script from here on.

1 Like

In doing some more research using xcode-select --install may work as well, need to test. For now I know for certain what I posted works, going to test and see what happens.

1 Like

Tried running xcode-select --install but still getting the same error.

“Can’t install the software because it is not currently available from the Software Update server.”

1 Like

Okay, good to know, will test anyways just for verification, but since that is the dependency from brew it should work. . .

1 Like

Have the same problem. homebrew’s install script prompts the CLT downloader, but it fails to find the file. Tried to download Xcode separately, then ran the homebrew installer again, but it’s still asking for the CLT.

I’m running this on a fresh MacOS 10.14.5 install (i recently cleaned up my computer).

1 Like

This is the file you want https://download.developer.apple.com/Developer_Tools/Command_Line_Tools_macOS_10.14_for_Xcode_10.2/Command_Line_Tools_macOS_10.14_for_Xcode_10.2.dmg

Obviously you’ll need to be logged into the developer site first.

1 Like

are you able to host the file somewhere else? I don’t have an Apple Developer account.

1 Like
2 Likes

awesome! installing homebrew now. thx a lot!

1 Like

You’re welcome, you should get a developer account though, this way you can get the files from the source.

2 Likes