Mariadb service running issue - need help reproducing or I'll close the issue


(Mark Essel) #1

Update found the issue
After reinstalling I tracked down the error to in my.cnf referencing UTC when running mysql_install_db
I changed that to +00:00 and the rest of installation worked great. I must have installed another plugin to convert string to timezone offsets

Uninstall and reinstalled mariadb and am having issues getting it to run.
Detailed information here

specifically seeing these errors in the log
2018-06-12 15:11:30 0 [Note] InnoDB: Loading buffer pool(s) from /usr/local/var/mysql/ib_buffer_pool
2018-06-12 15:11:30 0 [Note] InnoDB: Cannot open ‘/usr/local/var/mysql/ib_buffer_pool’ for reading: No such file or directory

and no such file / socket exists as far as I can see
messel@messels-MBP:~/Desktop/Dropbox/code/welcome/ops/sql$ ls -l /usr/local/var/mysql
total 246480
-rw-rw---- 1 messel admin 8192 Jun 12 15:11 aria_log.00000001
-rw-rw---- 1 messel admin 52 Jun 12 15:11 aria_log_control
-rw-rw---- 1 messel admin 50331648 Jun 12 15:11 ib_logfile0
-rw-rw---- 1 messel admin 50331648 Jun 12 14:35 ib_logfile1
-rw-rw---- 1 messel admin 12582912 Jun 12 14:35 ibdata1
-rw-rw---- 1 messel admin 12582912 Jun 12 15:11 ibtmp1
-rw-rw---- 1 messel admin 326607 Jun 12 15:11 messels-MBP.err
drwx------ 2 messel admin 64 Jun 12 14:35 mysql
-rw-rw---- 1 messel admin 24576 Jun 12 15:11 tc.log

if


(Mark Essel) #2

My bad:
After reinstalling I tracked down the error to in my.cnf referencing UTC when running mysql_install_db
I changed that to +00:00 and the rest of installation worked great. I must have installed another plugin to convert string to timezone offsets