Mac OS 10.15 Catalina issues

No, definitely nothing wrong with a forum thread, apologies if I implied otherwise. Just wanted to make sure everyone was aware :smile:

3 Likes

I’m also con Catalina beta. The error I’m running into is a “zlib module not found” in pip3 that makes it impossible to build some formulae.

Apparently the Mojave beta suffered from the same problem but the fix for Mojave does not appear to be applicable to Catalina.

greatlake:~ carlos$ pip3
Traceback (most recent call last):
  File "/usr/local/bin/pip3", line 11, in <module>
    load_entry_point('pip==19.0.3', 'console_scripts', 'pip3')()
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 489, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2793, in load_entry_point
    return ep.load()
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2411, in load
    return self.resolve()
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2417, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/local/lib/python3.7/site-packages/pip/_internal/__init__.py", line 19, in <module>
    from pip._vendor.urllib3.exceptions import DependencyWarning
  File "/usr/local/lib/python3.7/site-packages/pip/_vendor/urllib3/__init__.py", line 8, in <module>
    from .connectionpool import (
  File "/usr/local/lib/python3.7/site-packages/pip/_vendor/urllib3/connectionpool.py", line 36, in <module>
    from .response import HTTPResponse
  File "/usr/local/lib/python3.7/site-packages/pip/_vendor/urllib3/response.py", line 3, in <module>
    import zlib
ModuleNotFoundError: No module named 'zlib'
1 Like

Well, I managed to solve this. If anyone is interested, here is what I did:

  • Installed XCode 11 beta. I thought that after installing Catalina, the XCode offered by default by the App Store would be the 11 beta. However, I had XCode 10.2 installed.
    • in order to install Xcode 11, you have to download a 7.1GB package from developer.apple.com
    • what you get is some form of zip file that you have to expand and move to /Applications manually
    • then you run sudo xcode-select -s /Applications/Xcode-beta/
    • then you reinstall python brew reinstall python

So far I have built 4 or 5 formulae and all have worked fine.

My issue is just trying to reinstall yarn, it tries to install node and I always get stuck no matter how I try to build node or postgresql.

==> Reinstalling yarn
==> Installing dependencies for yarn: node
==> Installing yarn dependency: node
==> Downloading https://nodejs.org/dist/v12.4.0/node-v12.4.0.tar.gz
Already downloaded: /Users/ckizer/Library/Caches/Homebrew/downloads/b3002491cb5bd6b439bff3cec26583554588c31ae8512cbe1b13d43ecaec55f2–node-v12.4.0.tar.gz
==> ./configure --prefix=/usr/local/Cellar/node/12.4.0 --without-npm --with-intl=system-icu
Last 15 lines from /Users/ckizer/Library/Logs/Homebrew/node/01.configure:
2019-06-09 23:43:42 -0700

./configure
–prefix=/usr/local/Cellar/node/12.4.0
–without-npm
–with-intl=system-icu

ERROR: Did not find a new enough assembler, install one or build with
–openssl-no-asm.
Please refer to BUILDING.md

Do not report this issue to Homebrew/brew or Homebrew/core!

These open issues may also help:
node-build 4.6.1 https://github.com/Homebrew/homebrew-core/pull/40721

I get this error when I type node -v

node -v

dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.62.dylib
Referenced from: /usr/local/bin/node
Reason: image not found

I installed 10.15 Catalina yesterday. I had previously installed xcode 11-beta. Without thinking I ran my typical “brew update && brew upgrade && brew cleanup”. I initially got an error and the standard warning:

Error: undefined method `core_tap?’ for nil:NilClass
Warning: You are using macOS 10.15.
We do not provide support for this pre-release version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew’s GitHub,
Discourse, Twitter or IRC. You are responsible for resolving any issues you
experience, as you are running this pre-release version.

I got an error for one only one dependency in webpack:

Error: Your Xcode (10.2.1) is too outdated.
Please update to Xcode 11.0 (or delete it).
Xcode can be updated from:
https://developer.apple.com/download/more/

Easily fixed with: “sudo xcode-select -s /Applications/Xcode-beta.app”

After that… though I was holding my breath the whole time… everything installed fine.

Have you tried:
brew reinstall node or brew upgrade node

That’s what I can’t get to work at all.

My next fun problem is that, at least on my Mac OS 10.15 beta 1 machine,
/ != /foo/..

e.g.

buildbot@rbb-osx1015-1 cef % ls -ld /Applications /Users/../Applications
ls: /Users/../Applications: No such file or directory
drwxrwxr-x+ 7 root  admin  224 Jun  7 13:23 /Applications

This breaks cef 3497’s build, which tries to reach /Applications via a relative path, and therefore fails.

I don’t know whether brew is going to hit this, but it seemed worth mentioning…

Possible mind-bending workaround:

$ sudo ln -s /Applications /Users/../Applications

This may have something to do with the new readonly system volume feature, dunno.

Do you need an entire Xcode package or just Command Line Tools for Xcode 11 Beta? If I remember correctly, that was the only thing I needed with the past versions of Homebrew. Please do correct me if I’m wrong.

I couldn’t get the correct command line tools installed. Installing the full Xcode did it for me.

The directory isn’t working for me, while /Applications/Xcode-beta.app/ works for me.
After doing so, I can’t reinstall python by homebrew, I am using Catalina Beta 5 and here’s the error when I was running the reinstallment

It seems you are still running Xcode 10.15 Your version number for xcode-select should be
xcode-select version 2368.
run the command xcode-select --version and see what outputs
Have you opened Xcode 11 after your installed it? If you haven’t Open the application agree to the terms then try running the command sudo xcode-select -s /Applications/Xcode-beta.app/
hope this helps

Thanks for the reply, I already opened Xcode and set up the CLT to Xcode 11.0,
but it seems homebrew can’t find my CLT


Then it builds python from source and it fails to finish.

two things to try:

  1. What happens when you run xcode-select --install ?
  2. Try downloading the command line tools separately and see if that helps.
    https://download.developer.apple.com/Developer_Tools/Command_Line_Tools_for_Xcode_11_Beta_5/Command_Line_Tools_for_Xcode_11_Beta_5.dmg

Question:
Are you using bash, zsh, or zsh downloaded from homebrew? Catalina uses zsh now instead of bash
run the command which zsh to find out which one you are running
Additionally, you may need to update your xcode-beta. Please see the following :
https://developer.apple.com/documentation/xcode_release_notes/xcode_11_beta_5_release_notes#3318360

I find an issue(https://github.com/Homebrew/brew/issues/5002) which is exactly the problem I am facing. Yes, I need to download the CLT from https://developer.apple.com/download/more/. After I install the CLT, run command brew config


Anyway, the problem was fixed, thank you for your kindly help bro.

2 Likes

Is anyone able to install Python2 while running Catalina?

When running:

brew install python@2

I get the following error:

ln -fsn Versions/Current/Python Python.framework/Python

ln -fsn Versions/Current/Headers Python.framework/Headers

ln -fsn Versions/Current/Resources Python.framework/Resources

clang -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk -u _PyMac_Error Python.framework/Versions/2.7/Python -o python.exe \

                                            Modules/python.o \

                                            -ldl  -framework CoreFoundation

DYLD_FRAMEWORK_PATH=/private/tmp/python@2-20190827-29454-1pwlkv6/Python-2.7.16 ./python.exe -E -S -m sysconfig --generate-posix-vars ;\

            if test $? -ne 0 ; then \

                            echo "generate-posix-vars failed" ; \

                            rm -f ./pybuilddir.txt ; \

                            exit 1 ; \

            fi

/bin/sh: line 1: 35581 Segmentation fault: 11 DYLD_FRAMEWORK_PATH=/private/tmp/python@2-20190827-29454-1pwlkv6/Python-2.7.16 ./python.exe -E -S -m sysconfig --generate-posix-vars

generate-posix-vars failed

make: *** [pybuilddir.txt] Error 1

Anyone have any thoughts?

Looks like https://bugs.python.org/issue33374 ?

It looks like gettext won’t build under Xcode 11 (tried beta 6 and beta 7). Spews this:

ftello.c:53:12: error: no member named '_flag' in 'struct __sFILE'; did you mean '_flags'?
  if (fp_->_flag & _IOWRT)
           ^~~~~
           _flags
/Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/usr/include/_stdio.h:130:8: note: '_flags' declared here
        short   _flags;         /* flags, below; this FILE is free if 0 */
                ^
ftello.c:53:20: error: use of undeclared identifier '_IOWRT'
  if (fp_->_flag & _IOWRT)
                   ^
ftello.c:64:21: error: no member named '_flag' in 'struct __sFILE'; did you mean '_flags'?
          if ((fp_->_flag & _IONBF) == 0 && fp_->_base != NULL)
                    ^~~~~
                    _flags
/Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/usr/include/_stdio.h:130:8: note: '_flags' declared here
        short   _flags;         /* flags, below; this FILE is free if 0 */
                ^
ftello.c:64:50: error: no member named '_base' in 'struct __sFILE'
          if ((fp_->_flag & _IONBF) == 0 && fp_->_base != NULL)
                                            ~~~  ^
ftello.c:65:25: error: no member named '_ptr' in 'struct __sFILE'
            pos += fp_->_ptr - fp_->_base;
                   ~~~  ^
ftello.c:65:37: error: no member named '_base' in 'struct __sFILE'
            pos += fp_->_ptr - fp_->_base;
                               ~~~  ^
6 errors generated.

Since gettext is a dependency of ungodly lots of stuff, this hurts.

I’m not too proficient in C and macOS SDK differences to dig into it deeper, sorry.

An update. Guess I figured out the cause, but still no idea how to fix it.

The configure script for the gnulib component, which replaces “broken” libc functions with its own versions, checks for some undesired behavior of ftell(). It detects that on macOS, if you open a file in “r+” mode, read it up to EOF (by fseek()ing to its end, really), write one more byte, and call ftell() on it, the reported position will be wrong — the file pointer needs to advance as you write more data. There seems to be a known bug on Solaris, just like that.

So the configure script sets a variable telling that ftell() is broken on this system, but gnulib only has a replacement for Solaris, which uses the struct __sFILE as found there, and predictably barfs because __sFILE on Darwin is nothing like that.

How healthy an approach to patching systems that misbehave is left as an exercise to the reader, but here’s one thing: up to and including Mojave, ftell() was working just fine, and the replacement was never needed. Maybe, hm, someone more in the know should report it to Apple before they make a release?

XCode 11 beta 6 (haven’t tried beta 7) also makes openssl@1.0 segfault. A function accepts a pointer; at the callsite, it’s NULL, but in the function itself, it’s something bogus, which, upon dereferencing, gives a segfault. No idea whatsoever how that compiled. :-/

CLT for XCode Beta 7 seem to be unavailable (https://developer.apple.com/download/more/). Let’s see what tomorrow brings.