Llvm install fails when using --with-lldb option


(Michael Ellery) #1

I get the following error when installing the latest (6.0) llvm :

==> make install-xcode-toolchain
Error: inreplace failed
/usr/local/Cellar/llvm/6.0.0/share/clang/tools/scan-build/bin/scan-build:
   expected replacement of "$RealBin/bin/clang" with "/usr/local/Cellar/llvm/6.0.0/bin/clang"

If I remove the lldb option, build/install is successful. Does anyone know how to make the lldb option work?


(Node) #2

Go with these instructions
https://llvm.org/svn/llvm-project/lldb/trunk/docs/code-signing.txt