Installing macvim and getting errors

Hi there gents and gentettes, I am trying to start using macvim and I am following a guide that has a lot of the plugins and stuff i need called vimbox. To install this (https://github.com/jordwalke/VimBox) however some of the install process doesn’t work and i’m curious as to how to gt around it.

brew install macvim --with-cscope --python --HEAD

It said the cscope option was necessary so I tried this and i’m getting the errors:

Error: invalid option: --with-cscope

Also getting errors about the --python option.

That’s at least a year old tutorial then because those haven’t worked for a while. I’d drop everything after brew install macvim