Installation and other issues on High Sierra

(Praveen Prasannan) #1

Hey Folks,

Ever since I have upgraded to High Sierra, I am having issues with brew.

Couldn’t install few packages. Tried everything and finally uninstalled brew. Now I can’t install it. Somehow managed to reinstall. But cannot install any packages.

For eg: when I tried to install node, I am getting this error:

brew install node
==> Installing dependencies for node: icu4c
==> Installing node dependency: icu4c
Error: Permission denied @ rb_sysopen - /tmp/github_api_headers20171023-5020-upoqep

Could someone please help?

(Ash Dreyer) #2

Did you ever find a solution? I’m having this trouble too.

(Andy Wilkinson) #3

I am having similar problems with MariaDB on a fresh and clean install of High Sierra.

==> Pouring mariadb-10.2.11.high_sierra.bottle.tar.gz Warning: The post-install step did not complete successfully You can try again using `brew postinstall mariadb`

On doing this I get

==> Postinstalling mariadb Error: Permission denied @ dir_s_mkdir - /tmp/homebrew20171130-15621-18561us

If I check brew services I get:

dnsmasq started root   /Library/LaunchDaemons/homebrew.mxcl.dnsmasq.plist

mariadb started Andrew /Users/andrew/Library/LaunchAgents/homebrew.mxcl.mariadb.plist
nginx started root /Library/LaunchDaemons/homebrew.mxcl.nginx.plist
php71 started root /Library/LaunchDaemons/homebrew.mxcl.php71.plist

It seems it has started and running but when I connect to it

mysql -u root

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

stuck, any ideas?

(Chi) #4

see issue #3285. Basically, reinstall the homebrew should fix the problem.

you can use following reinstall command to reinstall
/usr/bin/ruby -e "$(curl -fsSL"