I'm not getting any love when it comes to dealing with my question

When I run ~ % brew doctor

My System Reports the following:

Please note that these warnings are just used to help the Homebrew maintainers with debugging if you file an issue. If everything you use Homebrew for is working fine: please don’t worry or file an issue; just ignore this. Thanks!

Warning: “config” scripts exist outside your system or Homebrew directories. ./configure scripts often look for *-config scripts to determine if software packages are installed, and which additional flags to use when compiling and linking.

Having additional scripts in your path can confuse software installed via Homebrew if the config script overrides a system or Homebrew-provided script of the same name. We found the following “config” scripts:


I’d like to get help fixing this/these warning(s)

I was hoping to see your system is ready to brew but I am not

Note: When I updated to Catalina, my system advised me to change the shell from bash to zsh, which I did. Now I am having to reinstall most of my Ruby on Rails Web Dev Env.

What exactly is the question? How do I get rid of the warnings it tells me to ignore?

Thank you for responding. My problems stem from me upgrading my MacBook Pro OSX to Catalina.

It turns out that `$ bash` is/has been replaced with `% zsh` and when I tried to update/upgrade brew 
my terminal asked me to run `% chsh zsh` (from memory?) and when I went to run % brew doctor it 
wasn't responding.

So I started from scratch and followed the brew guide and I'm left with these results after fixing any of 
the other problems.

These problems persist and I'd like to fix them if possible. I am not getting the `% 
your-ready-to-brew`, which I'm not sure is necessary. Are you able to offer guidance?

The first few lines literally say you can ignore the output unless you have issues do you’ll be fine even if it doesn’t say “ready to brew”.

Are you able to offer guidance on how to make my terminal look sane?

Why does it not look sane right now?

It’s my OCD.

How can I fix/remove/whatever the “config” scripts:?

If you don’t use pyenv for any development, you can fix this by just removing pyenv:

rm -r /Users/michelfrechette/.pyenv

Thank you for responding.

I want to use Python. I am attempting to turn my Mac into an Uber Web Dev Env.

In that case there’s nothing that can be done by us. You’ll have to ask the uber ops team to fix this for you.

What I mean by uber is: I want to set up my computer so that I am able to program in a number of 
programming languages such as ruby, python, etc.

There isn't an actual 'uber ops team' at least not as it relates to my question.

I appreciate your efforts to help me.


I solved the issue for pyenv there

But I still have the same problem with postgres.app, I cut and paste my solution:
alias brew='env PATH="${PATH//$(pyenv root)\/shims://Applications\/Postgres.app\/Contents\/Versions\/latest\/bin:/}" brew'