I receive an error when i try to tap 'homebrew/cask-cask' :-(

Hello friends,

I ran ‘brew doctor’. In the results it told me that some of my casks were deprecated and needed to be untapped. I misunderstood the instructions typed on my screen and just typed “brew untap cask” or something generic like that… without specifying an actual cask. Thus all my problems have begun and now anything I do I get this: “Error: caskroom/cask was moved. Tap homebrew/cask-cask instead.” but I cannot actually tap homebrew/cask-cask… It errors out. I’m not sure why. Any guidance/suggestions, etc. would be appreciated. I already ran “brew update-reset && brew update” but I still get the error. Thanks in advance for any recommendations or suggestions! Also, when I run ‘brew doctor’ I get this: Warning: Unknown support status. Here’s the output of my brew config:
HOMEBREW_VERSION: 2.4.9
ORIGIN: https://github.com/Homebrew/brew
HEAD: e6b066a3d9fc5435009428fcd2855fddf9b455c0
Last commit: 33 hours ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: adf7014d2c8b28e2263cd1daab668beff5e27130
Core tap last commit: 20 minutes ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_DISPLAY: /private/tmp/com.apple.launchd.scnULhRdUa/org.macosforge.xquartz:0
HOMEBREW_MAKE_JOBS: 4
CPU: quad-core 64-bit kabylake
Homebrew Ruby: 2.6.3 => /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/ruby
Clang: 11.0 build 1103
Git: 2.28.0 => /usr/local/bin/git
Curl: 7.64.1 => /usr/bin/curl
Java: 1.8.0_25
macOS: 10.15.6-x86_64
CLT: 12.0.0.0.1.1595091463
Xcode: 11.6
XQuartz: 2.7.11 => /opt/X11

This should say tap homebrew/cask instead.

i think so too… but if i type ‘tap homebrew/cask’ i get this (check out the last line).

jfreeman$brew tap homebrew/cask
Updating Homebrew…
==> Auto-updated Homebrew!
Updated 2 taps (homebrew/core and homebrew/cask).
==> Updated Formulae
Updated 45 formulae.
==> Updated Casks
alt-tab loom parallels-toolbox
anydo macintoshjs sound-siphon
daedalus-mainnet nvidia-geforce-now wechat
Error: caskroom/cask was moved. Tap homebrew/cask-cask instead.

Now run brew untap caskroom/cask to remove the old tap.

Here is what happened when I tried to untap caskroom/cask

jfreeman$brew untap caskroom/cask
Error: No available tap caskroom/cask.

???

meanwhile, every brew command I run finished with this ‘Error’:

Error: caskroom/cask was moved. Tap homebrew/cask-cask instead.

Weird. What does ls -ld $(brew --repo)/Library/Taps/*/* output?

jfreeman$ls -ld $(brew --repo)/Library/Taps//
drwxrwxr-x 16 jfreeman admin 512 Jul 27 17:08
/usr/local/Homebrew/Library/Taps/homebrew/homebrew-cask
drwxrwxr-x 13 jfreeman admin 416 Jul 13 10:36
/usr/local/Homebrew/Library/Taps/homebrew/homebrew-core
drwxrwxr-x 8 jfreeman admin 256 Jun 13 2018
/usr/local/Homebrew/Library/Taps/homebrew/homebrew-science
drwxrwxr-x 13 jfreeman admin 416 Jul 24 08:44
/usr/local/Homebrew/Library/Taps/homebrew/homebrew-services
drwxr-xr-x 7 jfreeman admin 224 Jul 9 14:47
/usr/local/Homebrew/Library/Taps/weaveworks/homebrew-tap

Curiouser and curiouser. How about:

$ ls -l $(brew --repo)/Library/Taps
$ grep -wr caskroom $(brew --repo)/Library/Taps

Also, what’s the full output of brew doctor?

That was helpful. I think the issue is in the .json file, no?

jfreeman$ls -l $(brew --repo)/Library/Taps
total 0
drwxrwxr-x 6 jfreeman admin 192 Jul 29 19:35 homebrew
drwxr-xr-x 3 jfreeman admin 96 Jul 9 14:47 weaveworks

jfreeman$grep -wr caskroom $(brew --repo)/Library/Taps
/usr/local/Homebrew/Library/Taps/homebrew/homebrew-science/tap_migrations.json: “r-gui”: “caskroom/cask/r-app”,

Let me know what you think. Let me know if you would still like to see the FULL output of brew doctor

THANKS!!!

I left this bit out:

jfreeman$grep -wr caskroom $(brew --repo)/Library/Taps
/usr/local/Homebrew/Library/Taps/homebrew/homebrew-science/tap_migrations.json: “r-gui”: “caskroom/cask/r-app”,
/usr/local/Homebrew/Library/Taps/homebrew/homebrew-cask/Casks/musescore.rb: # shim script (https://github.com/caskroom/homebrew-cask/issues/18809)

That’s almost certainly the cause of your problems: The homebrew/science tap (https://github.com/Homebrew/homebrew-science) was deprecated over 2 years ago, so it still refers to the equally defunct caskroom/cask tap. A quick brew untap homebrew/science should set things aright.

YES YES YES YES! Thank you!!! We’re all set here! I really appreciate the persistent assistance! :slight_smile: Have a great weekend!