I have problem with installation. Please help me!

==> Tapping homebrew/core

Cloning into ‘/usr/local/Homebrew/Library/Taps/homebrew/homebrew-core’…

fatal: Unable to find remote helper for ‘https’

Error: Failure while executing; git clone https://github.com/Homebrew/homebrew-core /usr/local/Homebrew/Library/Taps/homebrew/homebrew-core --depth=1 exited with 128.

Error: Failure while executing; /usr/local/bin/brew tap homebrew/core exited with 1.

Failed during: /usr/local/bin/brew update --force

Please!! Help me! I using Mac OS X 10.13.5 .

what does git --version say? And what macOS version are you using?

git version 2.18.0 and macOS High Sierra 10.13.5

Can you also tell me what ls $(git --exec-path) | grep https returns?

The result is git-remote-https

Are you on some kind of monitored (company) network?

I’m not sure. but I use my personal network .

I have fixed it. By running the command git clone https://github.com/Homebrew/homebrew-core /usr/local/Homebrew/Library/Taps/homebrew/homebrew-core --depth=1.Thank you for your help !!

2 Likes

Great to see it’s fixed!

I met the same situation. Thanks, this is really helpful!

1 Like

I had the same problem and the clone fixed it as well.

1 Like

I had the same problem and the clone mentioned ran smoothly