Home-brew ask me to download command line tools


(Haythem Ben Abdallah) #1

even though I have command line tools for macOS Mojave , home-brew ask me to download and install command line tools for macOS high Sierra and Sierra both , this even after a clean install


(Sean Molenaar) #2

The screenshot looks pretty normal, what does brew doctor say?


(Haythem Ben Abdallah) #3

I have already command line tools for xcode 10 but brew want me to install olders command line tool , i didn’t install it yet cuz it will download and install older verions from el capitain to high sierra


(Zj299792458) #4

I have the same issue.

In the installation script standalone command line tools is mandatory for unknown reason:

def should_install_command_line_tools?
return false if force_curl?
return false if macos_version < “10.9”

if macos_version > “10.13”
!File.exist?("/Library/Developer/CommandLineTools/usr/bin/git")
else
!File.exist?("/Library/Developer/CommandLineTools/usr/bin/git") ||
!File.exist?("/usr/include/iconv.h")
end
end

You can force it to skip and see what will happen.


(Sean Molenaar) #5

MacOS Mojave broke quite some parts developers rely on so just the Mojave commandline tools aren’t enough probably.


(Zj299792458) #6

use this script instead:

/usr/bin/ruby -e "ARGV=['--force-curl'] $(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

(LordChocorrol) #7

This script works pretty good.


(Viet Nguyen Tran) #8

Hello, can you provide some more information? What is the part?