Go compile failed on ARM 32bit cpu

I try to install go with linuxbrew but it fail
it seems like its related to the compile option ‘-race’
i am not familiar with go and have no idea what ‘-race’ option does. how can i make it work properly?
maybe add an ‘if’ statement to the formula to turn off the ‘-race’ option on arm 32bit cpu?

newbie@newbie:~$ brew install go
Updating Homebrew...
Warning: Your CPU architecture (arm) is not supported. We only support
x86_64 CPU architectures. You will be unable to use binary packages (bottles).
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew's GitHub,
Discourse, Twitter or IRC. You are responsible for resolving any issues you
experience while you are running this unsupported configuration.

==> Downloading https://dl.google.com/go/go1.14.1.src.tar.gz
######################################################################## 100.0%
==> Downloading https://dl.google.com/go/go1.9.linux-armv6l.tar.gz
######################################################################## 100.0%
==> ./make.bash --no-clean
==> /home/linuxbrew/.linuxbrew/Cellar/go/1.14.1/bin/go install -race std
Last 15 lines from /home/firefly/.cache/Homebrew/Logs/go/02.go:
2020-04-10 22:42:06 +0800

/home/linuxbrew/.linuxbrew/Cellar/go/1.14.1/bin/go
install
-race
std

go install: -race is only supported on linux/amd64, linux/ppc64le, linux/arm64, freebsd/amd64, netbsd/amd64, darwin/amd64 and windows/amd64

READ THIS:

You’ll need to figure this out yourself as the Homebrew maintainers do not support ARM CPUs.

Warning: Your CPU architecture (arm) is not supported. We only support
x86_64 CPU architectures. You will be unable to use binary packages (bottles).
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew’s GitHub,
Discourse, Twitter or IRC. You are responsible for resolving any issues you
experience while you are running this unsupported configuration.