Gnuplot fails to install terminals


(Runburg) #1

I recently went to install gnuplot on a new machine using Homebrew. I want gnuplot with the x11 and cairolatex terminals, so I included --with-x11 and --with-cairo. But these flags are now unrecognized. I have cairo up to date and xquartz so I have the necessary dependencies for these terminals. Now I don’t know how to add these terminals using Homebrew’s gnuplot.

Can someone help me figure out how to do this?


(Sean Molenaar) #2

Options have been deprecated because user builds are very unreliable. If you want to use a non-default install you’ll have to maintain your own version of the homebrew formula.


(Bertou) #3

With all due respect this is not a very welcome answer. The precise idea of homebrew is to not have to do that. If you go to https://formulae.brew.sh/formula/gnuplot you can see how many people tried --with-x11 in the last 30 days. It is a huge fraction of the user base, just because it is how many of us have been using gnuplot for years (and are still using it today on other platforms).
I understand it’s a bit rough to ask people to do some work to help everybody for free, but up to last gnuplot release in homebrew the --with-x11 option was available and worked fine for most people for sure. So basically a decision was taken, to remove that option, that impacts negatively on many of us.
Considering the number of requests shown on https://formulae.brew.sh/formula/gnuplot is there a chance to have the official packager add the option to the formula?


(Sean Molenaar) #4

Options for formula will not be reintroduced as they create an unreasonably high support burden. Even if it works fine for a majority, the support issues for options still outnumber the support issues for default installs.
Also, seeing how I’m one of the official packagers I don’t think adding back options will ever happen.


(Bertou) #5

Fine.
For other gnuplot users arriving to this post and in need of the X11 terminal, don’t be scared about compiling from sources or having to go through “unreasonably high burden”. To get gnuplot with x11 I had to:
go to gnuplot.info and get latest tgz
untar it, ./configure --with-x11, make, sudo make install
and it works flawlessly. Hope this can help other users that were let down by the latest homebrew gnuplot package


(Jan Viljanen) #6

We are not automatically saying that adding compilation options (compared to Formula options) are a no-no and you can submit a PR with the change you would like to see and have a discussion and argue for it there to make it the new default. As Sean said though the options will not return but changing what is produced in the standard formula is up for debate and mistakes and misinterpretations of the historic data can of course happen.


(Runburg) #7

Perhaps then adding a dependency on xquartz and providing the --with-x11 download automatically if the dependency is satisfied.

It seems that x11 is going by the wayside, but it is still the standard interactive terminal used with gnuplot.


(Bertou) #8

Well, let’s say that x11 is an unbloated terminal that many people seem to be using. At least all my colleagues and I are using it. Ubuntu-Linux by default uses wxt and all my colleagues and I have a “set term x11” at the start of their .gnuplot. Maybe that’s a dinosaur attitude but when working remotely on servers as many of us do all the bells and whistles of specific terminals pale compared to the speed of x11. And when one uses gnuplot it’s usually not to have a user friendly environment but mostly to have a quick and dirty way to plot. Then one uses python/c++ with whatever package to do the “real work”.
Given as I said earlier the statistics of how gnuplot is usually installed (as seen from homebrew formula) and that most webpages with instructions to install it suggest to add x11, it seems to me this is a reasonable option to add. I understand that if you move away from options (just tried to install opencv with the usual options and it failed, so I guess that’s a new system-wide decision that will impact the hundreds of webpage with help about how to instal xxxx on mac with homebrew, not sure this is a good idea but I’m sure you gave a long thought to that before taking the decision), it means it has to be a new default. I don’t know how many people had gnuplot without xquartz before, maybe that’s the data you need to take the decision. I’d be happy to overwrite my manual installation with the homebrew one for sure if ever x11 is available in it.