GiNaC dependency of Python 2?

I was wondering why ginac.rb still depends on Python 2:

which leads to failing to install GiNaC on Linux due to:

Indeed, the INSTALL file of GiNaC 1.7.8 mentions Python 3 as a prerequisite:

https://www.ginac.de/ginac.git/?p=ginac.git;a=blob_plain;f=INSTALL;hb=f2051c351d8f9791a4afcc8d03465bf100a8088d

So, I think it should be depends_on "python" unless there is some macOS specific compatibility problem. (I am a Linux user, so it is difficult to check if it works well on macOS.)

Could you make a pull request to change it in homebrew-core? We’ll see soon enough of the tests fail or if there was just a problem porting it in the past.

Thank for your reply. Then, I will make a pull request for this.

The pull request is https://github.com/Homebrew/homebrew-core/pull/50280. The check has passed.