Getting started. "def install" worked so far but got "Error: Empty installation" at the end


(Pvbrowser) #1

I’m currently starting to use HOMEBREW for our project pvbrowser dot org
It seems to build, but some issues are left.

At the end of “install” i get the message
"Error: Empty installation"
But definitely the generated executables and libraries of our project are there and they are working.

The second issue is that currently i must use a shell scipt "set-links.sh"
after brew in order to set the links (because from within brew the privileges seem to be missing).

Please give me some hints.

Here is the set-links.sh script

#!/bin/bash
ln -sf /usr/local/Cellar/pvb/pvbrowser/pvbrowser                     /usr/local/bin/pvbrowser
ln -sf /usr/local/Cellar/pvb/pvdevelop/pvdevelop                     /usr/local/bin/pvdevelop
ln -sf /usr/local/Cellar/pvb/start_pvbapp/start_pvbapp               /usr/local/bin/start_pvbapp
ln -sf /usr/local/Cellar/pvb/rllib/rlsvg/rlsvgcat                    /usr/local/bin/rlsvgcat
ln -sf /usr/local/Cellar/pvb/rllib/rlfind/rlfind                     /usr/local/bin/rlfind
ln -sf /usr/local/Cellar/pvb/rllib/rlhistory/rlhistrory              /usr/local/bin/rlhistory
ln -sf /usr/local/Cellar/pvb/rllib/rlhtml2pdf/rlhtml2pdf             /usr/local/bin/rlhtml2pdf
ln -sf /usr/local/Cellar/pvb/language_bindings/lua/pvslua/pvslua     /usr/local/bin/pvslua
ln -sf /usr/local/Cellar/pvb/language_bindings/lua/pvapplua/pvapplua /usr/local/bin/pvapplua
ln -sf /usr/local/Cellar/pvb/fake_qmake/fake_qmake                   /usr/local/bin/fake_qmake
export  real_qmake=$(find /usr/local/Cellar/qt -name qmake)
ln -sf $real_qmake                                                   /usr/local/bin/qmake
#ln -sf /usr/local/Cellar/qt/5.10.0/bin/qmake                        /usr/local/bin/qmake

ln -sf /usr/local/Cellar/pvb/rllib/lib/librllib.dylib /usr/local/lib/librllib.dylib
ln -sf /usr/local/Cellar/pvb/rllib/lib/librllib.dylib /usr/local/lib/librllib.1.dylib
ln -sf /usr/local/Cellar/pvb/rllib/lib/librllib.dylib /usr/local/lib/librllib.1.0.dylib
ln -sf /usr/local/Cellar/pvb/rllib/lib/librllib.dylib /usr/local/lib/librllib.1.0.0.dylib

ln -sf /usr/local/Cellar/pvb/pvserver/libpvsid.a  /usr/local/lib/libpvsid.a
ln -sf /usr/local/Cellar/pvb/pvserver/libpvsmt.a  /usr/local/lib/libpvsmt.a

ln -sf /usr/local/Cellar/pvb /opt

(Pvbrowser) #2

The issue can be reduced to the question:

Can i run the set-links.sh script from within the brew formula ?
or
Must the User run it with sudo after the installation with brew ?


(Pvbrowser) #3

My issue seems to be the same as:

What is the official statement according to this problem?