Ffmpeg 4.2.1 and openssl 1.1 dependency

Hello,

Until now I was able to compile an app using Qt5.5 (depending on openssl 1.0) with ffmpeg installed via homebrew. I just reinstalled everything on a 10.12 (osx) machine this morning and was unable to make my app work because, I think, of this change I noticed in libavformat.dylib : it now depends on openssl 1.1 (conflict with qt5.5 needs).

I could not find anything on when and why it changed, and I wonder if it has something to do with my config (the version of xcode I use, etc)…

Does anybody have some info to share ?

thanks in advance.

Why am I never getting any answer in this forum…

Just to let you know, I found an old 10.11 with ffmpeg 4.0 installed on it (with an old homebrew) and with otool -L .../libaformat.dylib I don’t even see an openssl dylib dependency, so I have a new question.

Whay OpenSSL has been added as a dependency on ffmpeg ? Does anybody know where I could find some answers ?

thanks again.

You can look at the git history for the homebrew formula.