Failed to set locale category LC_NUMERIC to en_RU

If you experience more WARNING like me, you could check the following:

First, “export LC_ALL=en_US.UTF-8” and “locale” to see if it works, then echo $SHELL, edit .bashrc or .zshrc(depending which shell you’re currently using), make sure to put “export LC_ALL=en_US.UTF-8” at the first line, restart your terminal.

2 Likes

I have zsh installed.
I’ve edited this file: ~/.zshrc
Added:
export LC_ALL=en_US.UTF-8

2 Likes

Yes, I my case I was getting the same error.

I am a MAC Book user, so adding export LC_ALL=en_US.UTF-8 to ~/.bash_profile solved my problem.

After that you have to run source ~/.bash_profile and that’s it.

2 Likes

If you are already using zsh, you might aswell use the proposed default from your ~/.zshrc and enable this line:

# You may need to manually set your language environment
export LANG=en_US.UTF-8

This will give you a cleanly configured locale setup:

 ~ locale
LANG="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_CTYPE="UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_ALL=
2 Likes

Thank you for the suggestion!

Thanks George, it worked.

1 Like

Work’s Perfect!!! Thank you for the suggestion!

I had to put the locale exports in the TOP of ~/.zshrc in order to work.
I had trouble running gpg-agent plugin due to locale misconfiguration.
I suppose you have to declare locale before plugins in .zshrc.

1 Like

Yessss, thank you this worked for me!!