Error: Xcode alone is not sufficient on Yosemite - Tried everything I can think of please help


(Micah) #1

I updated homebrew, and installed some OS updates this morning and something broke on my system that is causing the following error:

Error: Xcode alone is not sufficient on Yosemite.
Install the Command Line Tools:
xcode-select --install

Browsing the internet I found many possible solutions but none of the ones I tried fixed the issue.
I am hoping someone here has some ideas on how to fix this. I suspect it is related to this post:

Also probably related to the fact that CLT says N/A in the brew config below.

Versions:

  • OS Yosemite version 10.10.5 (I cannot upgrade unfortunately)

  • Homebrew:
    Homebrew 1.5.10
    Homebrew/homebrew-core (git revision 72c8; last commit 2018-03-13)

  • xcode-select version 2339.

Brew config:

HOMEBREW_VERSION: 1.5.10
ORIGIN: https://github.com/Homebrew/brew
HEAD: 04efbadb9ef155c5921a03bf5f5d9052cd378c21
Last commit: 3 days ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: 72c88ef9d79048295b42d2e879e7a691b7f5dac6
Core tap last commit: 50 minutes ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_RUBY_WARNINGS: -W0
CPU: octa-core 64-bit haswell
Homebrew Ruby: 2.3.3 => /usr/local/Homebrew/Library/Homebrew/vendor/portable-ruby/2.3.3/bin/ruby
Clang: 7.0 build 700
Git: 2.5.4 => /Applications/Xcode.app/Contents/Developer/usr/bin/git
Curl: 7.43.0 => /usr/bin/curl
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby
Java: 1.8.0_66, 1.7.0_80, 1.6.0_65-b14-468
macOS: 10.10.5-x86_64
Xcode: 7.2
CLT: N/A
X11: N/A

Stuff I’ve tried (not necessarily in order):

  • Initially tried updating homebrew.
  • Uninstalled and reinstalled homebrew.
  • Ran brew doctor and prune.
  • Made sure xcode was installed and updated.
  • Tried installing an older version of homebrew.
  • Ran “xcode-select -r” hoping something was misconfigured.
  • Removed command line tools at: /Library/Developer/CommandLineTools and reinstalled (via command line and using the app store)

At this point I’m at a loss as to what to do. Any suggestions would be greatly appreciated.

Thanks!.


(Eduard Rozenberg) #2

Have you already tried ‘xcode-select --install’ ? It’s not entirely clear from your post if you’ve already done that. Xcode does have its own command line tools, but installing the standalone command line tools package in addition is definitely worth trying.

It’s also possible to download the standalone command line tools package from Apple dev downloads (if you have an Apple developer account):
https://developer.apple.com/download/more/

The appropriate package there for your OS appears to be Command Line Tools OS X 10.10 for Xcode 7.2.dmg from Dec 7, 2015.

I don’t know whether Homebrew is still tested and known to work with Yosemite, but have no reason to think it would be a problem. I don’t have any Yosemites running to try on. :slight_smile:

–Ed