Emacs with X11 support?


(Douglas Alan) #1

Hi. Is there still a Homebrew version of Emacs with X11 support? I just got a new iMac that runs Sierra, and I couldn’t find such a version of Emacs in Homebrew.

I used to provide Homebrew with the “–with-x” option when installing Emacs, and that worked great. But that option is now missing.

Thanks!

|>oug

P.S. If there is no Homebrew X11 Emacs, I guess it’s not the end of the world, though it is a bit of a pain. I have resorted to installing Fink just to get an X11 Emacs. I built Fink from source and relocated it to /fink rather than /sw, and I don’t have /fink/bin in my path, all so that Fink won’t cause conflicts with Homebrew. It took many hours for Fink to do all the compiling that it needed to do to make this happen, however, so it clearly would be a lot more convenient to have an X11 version of Emacs available via Homebew.


(Geoff Mac Intosh) #2

You need to use Emacs-plus, which is a third party tap that has a bunch of options not available in core, including X11. It’s really good times.


(Douglas Alan) #3

Thanks!!!

Is there a secret to getting it to install right? I installed it like so:

$ brew tap d12frosted/homebrew-emacs-plus
$ brew install d12frosted/emacs-plus/emacs-plus --with-x11

And then I found the X11 version of Emacs in

/usr/local/Cellar/emacs-plus/25.2/bin/emacs-25.2

When I run it, however, it doesn’t work right. I.e., it doesn’t get keyboard focus. I.e., if I click on it and type, all my typing goes goes into a different window, not into Emacs.

This is in contrast to the X11 version of Emacs that I installed via Fink, which works fine.

Thanks for your help!
|>oug


(Geoff Mac Intosh) #4

To be honest, I’ve never used the X11 version of Emacs, I just use the emacs-plus tap and know it has the X11 option. I think there are a few likely problems:

  1. X11 hates having two versions of emacs linked. I don’t really understand how X11 works, so that might not make sense.
  2. There’s a bug in emacs-plus’s --with-x11 option. Maybe try opening an issue on their GitHub page?
  3. Magic.

I’ll install that version of Emacs on my desktop and see if I also have weirdness.


(Douglas Alan) #5

X11 doesn’t mind having 1,000 versions of Emacs linked. There must be something wrong with the recipe, alas.

|>oug