Duplicate Formulae: "python" & "python3"


Shouldn’t python3 be removed (automatically) with the new python update?

I manually cleaned up by running:

$ brew list 
both python and python3 present

$ brew uninstall --ignore-dependencies python

$ brew list
neither python nor python3 present

$ brew install python --with-tcl-tk

$ brew list
only python present, python3 gone

$ python
Python 3.6.4

Brew install python3 fails
(Mike McQuaid) #2

If you run brew update and brew upgrade you should only see a python and python@2 formula. If this is not the case: please file an issue (and follow the template). Thanks!

(Inada Naoki) #3

In my case, there is “python3@ -> python” symlink is remained in Celler.
I fixed it manually by:

$ cd /usr/local/Cellar/
$ unlink python3


Thanks Mike! Unfortunately I can no longer check if brew update && brew upgrade will fix the problem now and I’m unsure if I already tried running that before I did my manual fix. Therefore I won’t open issue. We’ll see if others come to this thread with the same problem. If so, happy to open one.

(Mike McQuaid) #5

Note: we are changing the behaviour of Python 2 and 3 tomorrow: Python and PEP 394