Desire to add X11 support back into imagemagick

X11 support was one of the options removed from IM in the upgrade to 2.0. Unfortunately for me, it was one of the features I frequently used. Removing it renders IM significantly less useful for me. I’ve reverted to an earlier version for now, but what’s the best way to go about getting it restored? Do a PR, start this discussion here?

TIA.

As X11 support is terrible on macOS it probably won’t be a default (though you could always make a PR).
That leaves you with maintaining your own tap.

I can confirm it definitely will not be the default as X11 does not ship with macOS.

Do I understand correctly that hoping for the option to be restored will be in vain?

Yes, options won’t be back either way.

I used them sparingly, but for good reason.

It’s a really frustrating situation for those of us who rely on these X-native applications. Check my post history for my similar struggle regarding gv. I was eventually able to get a tap in place and am back to full functionality. If you go the same route, please let me know if you have any trouble and I’ll try to help.

I may try this route, but I haven’t yet looked into how to maintain my own tap.

@Jmuccigr I have it here on my tap: https://github.com/blogabe/homebrew-xplanet/blob/master/imagemagick.rb

It’s the last imagemagick prior to options removal, but updated w/ latest version.

1 Like

Hello @jmuccigr, I would like to try using your tap to get imagemagick with png support on Mac OS X Mojave. I am not sure how to properly use your tap. Can you please give instructions?

I have tried

brew tap blogabe/homebrew-xplanet

and now my brew tap returns:

(base) cu-vpn-nsidc-172:~ brodzik$ brew tap

blogabe/xplanet

d12frosted/emacs-plus

homebrew/core

However, when I do ‘brew info imagemagick’ it’s still returning information from homebrew/core. So I don’t know how to force it to use your tap.

Thank you.
MJ

You can try brew info blogabe/xplanet/imagemagick and that should resolve to the one in the tap. Similarly, you would do brew install blogabe/xplanet/imagemagick.

You will also want the flags set for the options you want. I use --with-x11 --with-fftw.

Thank you both–it worked to specify the tap name along with the formula. It took me a while to figure it out. I am using a custom tap for emacs and they renamed it to emacs-plus, so I was confused why this was different. It actually makes sense that, when the formula in the custom tap is the same name as a formula in homebrew-core, then you need to use the fully-qualified name. Hopefully this will help someone else along the way. (And thank you for setting up the custom tap, I rely on imagemagick for a lot of work with .pngs).

I was not aware of the xplanet tap so I created a homebrew imagemagick X11 drop-in replacement formulae that can be used like this:

brew uninstall imagemagick  # without x11 support
brew cask install xquartz
brew install tlk/imagemagick-x11/imagemagick

It tracks the core-formulae but keeps X11 enabled.