Current percona-xtrabackup is incompatible with mysql 8.0 and percona-server 8.0

Hi,

If you install mysql or percona-server, you get version 8.0 by default. But for larger databases, you will definitely need incremental, binary backups (mysqldump is neither). And percona-xtrabackup is the obvious choice. Percona does not offer an installer for MacOS.

We’d like to use Percona Server 8.0, but we need backups to work. Since Xtrabackup 2.4 does not support PS 8.0, we had to downgrade to PS 5.7.

I saw the comment here, but there is no information about when percona-xtrabackup will be updated?

Thanks,

Mattias

Whenever someone puts in the work, it’s that simple

1 Like