Compiling ffmpeg without using a bottle


(Lbutlr) #1
brew reinstall ffmpeg  --with-x265
==> Reinstalling ffmpeg --with-x265
 ==> Downloading https://homebrew.bintray.com/bottles/ffmpeg-4.0.2.high_sierra.bottle.tar.gz
 Already downloaded: /Users/lbutlr/Library/Caches/Homebrew/ffmpeg-4.0.2.high_sierra.bottle.tar.gz
 ==> Pouring ffmpeg-4.0.2.high_sierra.bottle.tar.gz
 🍺  /usr/local/Cellar/ffmpeg/4.0.2: 246 files, 49.7MB
 # ffmpeg -version
 ffmpeg version 4.0.2 Copyright (c) 2000-2018 the FFmpeg developers
 built with Apple LLVM version 9.1.0 (clang-902.0.39.2)
configuration: --prefix=/usr/local/Cellar/ffmpeg/4.0.2 --enable-shared --enable-pthreads --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-gpl --enable-libmp3lame --enable-libx264 --enable-libxvid --enable-opencl --enable-videotoolbox --disable-lzma
 libavutil      56. 14.100 / 56. 14.100
 libavcodec     58. 18.100 / 58. 18.100
 libavformat    58. 12.100 / 58. 12.100
 libavdevice    58.  3.100 / 58.  3.100
 libavfilter     7. 16.100 /  7. 16.100
 libavresample   4.  0.  0 /  4.  0.  0
 libswscale      5.  1.100 /  5.  1.100
 libswresample   3.  1.100 /  3.  1.100
 libpostproc    55.  1.100 / 55.  1.100

So, how do I get it to actually compile with x265 instead of pouring bottle without x265.


(Sean Molenaar) #2

Afaik reinstall just reinstalls the current state, regardless of options. To install it again with different options you’d need to remove the install and then install it again. brew remove ffmpeg && brew install ffmpeg --with-options


(Lbutlr) #3

Doesn’t make any difference (have done this on both Mojave and High Sierra)

# brew remove ffmpeg
Uninstalling /usr/local/Cellar/ffmpeg/4.0.2... (246 files, 49.7MB)
# brew install ffmpeg  --with-x265
==> Downloading https://homebrew.bintray.com/bottles/ffmpeg-4.0.2.high_sierra.bottle.tar.gz
Already downloaded: /Users/lbutlr/Library/Caches/Homebrew/ffmpeg-4.0.2.high_sierra.bottle.tar.gz
==> Pouring ffmpeg-4.0.2.high_sierra.bottle.tar.gz
🍺  /usr/local/Cellar/ffmpeg/4.0.2: 246 files, 49.7MB
# ffmpeg -version
ffmpeg version 4.0.2 Copyright (c) 2000-2018 the FFmpeg developers
built with Apple LLVM version 9.1.0 (clang-902.0.39.2)
configuration: --prefix=/usr/local/Cellar/ffmpeg/4.0.2 --enable-shared --enable-pthreads --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-gpl --enable-libmp3lame --enable-libx264 --enable-libxvid --enable-opencl --enable-videotoolbox --disable-lzma
libavutil      56. 14.100 / 56. 14.100
libavcodec     58. 18.100 / 58. 18.100
libavformat    58. 12.100 / 58. 12.100
libavdevice    58.  3.100 / 58.  3.100
libavfilter     7. 16.100 /  7. 16.100
libavresample   4.  0.  0 /  4.  0.  0
libswscale      5.  1.100 /  5.  1.100
libswresample   3.  1.100 /  3.  1.100
libpostproc    55.  1.100 / 55.  1.100

(Filip Navara) #4

What does brew config output? When I had similar issue recently it had HOMEBREW_FORCE_BOTTLE: 1 option there.

Reference: https://github.com/Homebrew/brew/pull/4520


(Lbutlr) #5

Yes, how did it get there and how do I reset it to 0?


(Sean Molenaar) #6

If that is set to 1 you have it defined somewhere in your shell config. You can change it there.


(Mike McQuaid) #7

We need your brew config output.