Catalina Released - Any major issues?

Title. I see that Mac OS 10.15 Catalina was released to the public today. Just curious what major issues you may have seen (if any). I mostly use Homebrew for web development, so I mostly have composer, php, mariadb, git, imagemagick, mongoldb, nginx, node, nvm, redis, yarn, among a ton of others installed. I also use Valet… so just looking for feedback from others before attempting to update. Thanks in advance!


Well, I just updated to Catalina and seems like Brew hasn’t been updated for it yet, as I’m still getting the pre-release warning, even though I’m on the official release.
I did get a few network errors when running the update command (probably specific to me), and some compile errors, just need to re-install xcode, but other than that it’s been working fine so far.

Warning: You are using macOS 10.15.
We do not provide support for this pre-release version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew’s GitHub, Discourse, Twitter or IRC. You are responsible for resolving any issues you experience while you are running this pre-release version.

1 Like

I’m getting a similar issue with my version of ruby when I try to run brew doctor along with the pre-release message.

Blockquote Warning: Ruby version 2.6.3 is unsupported on 10.15. Homebrew

is developed and tested on Ruby 2.3.7, and may not work correctly

on other Rubies. Patches are accepted as long as they don’t cause breakage

on supported Rubies.

I’ll try to install the latest version of Ruby and run the install script to see if I can get that message to go away.

1 Like

There are some packages that will not work, especially casks due to dropping x86 support, but at least.

I’m personally just going through my major packages on my test 2017 MBP 13" which got a “clean” install of Catalina.

I too am having the ruby issue.

brew install ruby installed 2.6.5p114 and I added the:

echo 'set -g fish_user_paths "/usr/local/opt/ruby/bin" $fish_user_paths' >> ~/.config/fish/
set -gx PKG_CONFIG_PATH "/usr/local/opt/ruby/lib/pkgconfig"

and when I ruby -v I get the 2.6.5p114 version # but brew doctor still displays the 2.6.3 error message.

this error is preventing me from using macvim:

~ ▶︎︎ mvim
dyld: Library not loaded: /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/libruby.2.3.0.dylib
  Referenced from: /usr/local/Cellar/macvim/8.1-154/
  Reason: image not found
fish: 'mvim' terminated by signal SIGABRT (Abort)

just restarted because that is the fix for everything and my brew doctor no longer had the 10.15 warning or the ruby warning. I do have an xcode warning now but xcode keeps failing to update.

Update: Just completely removed xcode with all associated files and reinstalled via the app store and it appears to be working.

brew doctor has no errors but mvim still doesn’t work because of the above ruby issues.

Update 2: brew install macvim --HEAD seems to be working on 10.15 without issue.

After upgrading to Catalina I got

$ wine
-bash: /usr/local/bin/wine: Bad CPU type in executable

Is it homebrew issue or wine issue? I mean where to report? :slight_smile:

MacOS 10.15 (19A583)


I upgraded to MacOS Catalina 10.15.
When I did brew update yesterday, the warning about “We do not provide support for this pre-release version” disappeared.
I was able to install gcc, python (and the mactex cask) without any issues.

1 Like

I got this message; ran the command line to fix it
Your Xcode is configured with an invalid path.
You should change it to the correct path:
sudo xcode-select -switch /Applications/

I received similar unsupported messages
I will wait for updates to brew before making any major changes or updates

Hi, found issue with installation homebrew on clean macOS Catalina.

Installation of Command Line Tools step fails because of new output format of softwareupdate --list tool.
Logged the issue

I haven’ tried Valet but if you’re running something with Ansible, do not update yet. There are some issues with the NFS filesystem and Ansible still working on solving it. So heads up!

1 Like

I find issue on dpkg packages. It installs only Mojave supported dpkg packages. Any idea when dpkg developers release ffor MacOS Catalina. I couldn’t able to install any .deb files properly in Catalina.

I Have this problem.

İf you fixed the this problem please contact with me.

mail :

Hi to all
I have fixed my problems with brew in catalina using the following steps:

  1. Upgrade Catalina (there is an upgrade to it)
  2. Download Xcode command line form the developer site
  3. Upgrade Ruby to 2.6.5
  4. Clear Cellar folder and brew cache (make backup of app lists)
  5. Reinstall brew
    It worked for me.

cvs does not work anymore. Yes, I know it is 2019, but

$ cvs upd -d
cvs [update aborted]: cannot get working directory: No such file or directory

This: seems to have a patch for cvs to get it fly again. Any suggestions how to get it published in the brew repo?


Make a pull request adding the patch. It’s that easy.

Traceback (most recent call last):
	3: from /usr/local/Homebrew/Library/Homebrew/brew.rb:23:in `<main>'
	2: from /usr/local/Homebrew/Library/Homebrew/brew.rb:23:in `require_relative'
	1: from /usr/local/Homebrew/Library/Homebrew/global.rb:12:in `<top (required)>'
/usr/local/Homebrew/Library/Homebrew/global.rb:12:in `require': cannot load such file -- active_support/core_ext/object/blank (LoadError)

Just got this issue after running following commands
brew update
brew upgrade
brew cleanup

Now I cannot run any commands. Please help.

1 Like

I did exactly the same thing after my upgrade to macOS Catalina 10.15 general availability version, and I got the same error. Hope someone comes up with a fix ASAP!

What I did was reinstall the brew again which updated the xcode command line tools and now its working. Seems issue was with outdated command line tools.


trying to compile glfw/sfml hello world shows me this:

dyld: Library not loaded: /usr/local/opt/sfml/lib/libsfml-window.2.5.dylib

Referenced from: /Users/vlad/Library/Developer/Xcode/DerivedData/hello-ctfsvrxsgcorxxcwgwvrtpzlxsyn/Build/Products/Debug/hello

Reason: no suitable image found. Did find:

/usr/local/opt/sfml/lib/libsfml-window.2.5.dylib: code signature in (/usr/local/opt/sfml/lib/libsfml-window.2.5.dylib) not valid for use in process using Library Validation: mapped file has no cdhash, completely unsigned? Code has to be at least ad-hoc signed.

/usr/local/lib/libsfml-window.2.5.dylib: code signature in (/usr/local/lib/libsfml-window.2.5.dylib) not valid for use in process using Library Validation: mapped file has no cdhash, completely unsigned? Code has to be at least ad-hoc signed.

/usr/local/Cellar/sfml/2.5.1/lib/libsfml-window.2.5.1.dylib: code signature in (/usr/local/Cellar/sfml/2.5.1/lib/libsfml-window.2.5.1.dylib) not valid for use in process using Library Validation: mapped file has no cdhash, completely unsigned? Code has to be at least ad-hoc signed.

when doing make install (without brew) for glfw it works ok. macos catalina, xcode 11.1

1 Like