Can't install intl on PHP 7.2

Hi. I’m using MacOS 10.14.6

I’ve upload my Apache server to the last one (2.4.39) ( brew install httpd) I'm installing packages using brew (2.1.9) I've install PHP 7.2.20 ( brew install php@7.2)
I’ve removed the ; from ;extension=intl in php.ini ( code /usr/local/etc/php/7.2/php.ini) I've install intltool ( brew install intltool)

Restarting apache, intl is not been loaded. Tested with:
php -v
php -i | grep intl
php -m | grep intl

I’m getting always errors in finding intl extension. I’m trying to add the path to php.ini, but I don’t find intl.so in /usr/local/Cellar/php@7.2/7.2.20/

any help?

are you using /usr/local/opt/php@7.2/bin/php if you check which php? Cause otherwise you’re testing if the macOS version includes intl.

brew install intltool is not installing anything related to php by the way.

Hi.

I’ve solved the issue. it was just my fault for editing the php.ini file and enabling manually the intl.dll extension. In this package the intl is enabled by default, so there is no need of enabling it manually by editing the php.ini file. What was failing was the load of the intl.dll and I’m in MacOS… so I was a little stupid… Thanks anyway