Can't Enter Password


(Saint Somnia) #1

Hello. I’m having trouble installing homebrew. I write the command into the terminal, and it asks me to input my password, but it won’t let me actually type anything in? I’m not sure what to do.


(Mike McQuaid) #2

The characters won’t be output but just type the password and hit enter anyway.


(Mackenzie) #3

What password goes here. I’m confused


(Mike McQuaid) #4

Your user password for your admin user.


(Saint Somnia) #5

Ah, I see. You’d think that would be obvious. Thank you!


(Anotheroldgit) #6

I am having an identical issue trying to install Homebrew on Mavericks. I have tried installing it from my user account using both my regular administrator password and also my root password, but cannot get Terminal to accept anything I type when it asks for a password.

I also tried logging in as root and installing from there, but got an error message saying this was not allowed: “Don’t run this as root!”

I’m stumped and would very much appreciate advice on how to get this useful piece of kit installed on my Mac.


(Franklin Yu) #7

Try this:

sudo echo hello

See if it gives any error message.


(Anotheroldgit) #8

Thanks for replying. I get a password prompt here too, with the same result.


(Franklin Yu) #9

Does “with the same result” means that neither your administrator password nor your root password passes the authentication? If that’s the case, I guess there’s something wrong with your system, not specific to Homebrew. Are your password pure ASCII? And you did manage to log in with the same password, did you?


(Anotheroldgit) #10

That’s right - neither the admin password nor the root password. I can log into root but once I’m in there I get this “Don’t run this as root” message when I try to install Homebrew from that account. On my main user account I can get as far as the installation but not the verification. It stalls at the password stage.
I’m a complete noob when it comes to Unix, so I have never knowingly used sudo. Therefore however it is configured on my computer is how it was when I bought it. The only change I’ve made is to set up a root password.


(Franklin Yu) #11

That’s weird. Have you ever modified any file under /etc/ folder?

Since your issue doesn’t seem specific to Homebrew, I suggest to search in Stack Exchange with keywords like “cannot sudo”. Create a new question if you can’t find one; you’ll get better answer there, rather than here.

By the way, Apple discourage enabling the root user:

The root user account is not intended for routine use.

I have been developing on my macOS for two years, and I have never found any case where it’s necessary to enable the root user account.


(Anotheroldgit) #12

Never! I have absolutely no clue how any of that stuff works. I only enabled root in order to try and install Homebrew. This would have been the first modification I’d’ve made to the system.

Will definitely pursue this at Stack Exchange. I really appreciate your advice here - many thanks for taking the time.


(Franklin Yu) #13

Homebrew explicitly discourage using with root user account. I guess you are misled by some poorly written tutorial.


(Anotheroldgit) #14

Indeed I was. It does look as though the problem is sudo, and I will need to figure out how to fix that, as I guess I won’t be able to install Homebrew until I do. Thanks for your help.


(Ok45sg) #15

I reckon this is due to the contrary advice given. @anotheroldgit I saw this advice given to create root password as the solution when the same question was posted there. Also https://teamtreehouse.com/community/password-prompt-for-homebrew

I did sudo echo hello and it asked for password.

I have never used any password and no one uses this Mac. So I hit enter to the question by Sudo and it invalidates my response. I can’t install homebrew.
So what next, please help.


(Ok45sg) #16

Hi, I solved it. I merely created an admin password where initially there wasn’t. I have installed Homebrew. My password is made of small caps letters and numbers 8 characters without spacing.
I didn’t install root password (what’s that?). Hope this helps.


(Casey Shultz) #17

That worked. Thanks!