Brew want install xcode command line tool but I have it?


(Naserkhosravi) #1

When I want install Homebrew by following command in terminal:

ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”

it offer me : The Xcode Command Line Tools will be installed.

But i have the Xcode command line tool I detects this by terminal
xcode-select --version
xcode-select version 2349.

Please guide me how I should resolve this?


(Eduard Rozenberg) #2

That tells you the version of the xcode-select tool, as it says: print the xcode-select version. Says nothing about whether you have cli tools installed.

Homebrew is basically doing xcode-select --install which you can also run yourself to install cli tools, before setting up homebrew.

Even if you have Xcode installed, you may not have cli tools yet. Let xcode-select --install do its thing before trying to use homebrew.