Brew uninstall smartmontools failed, it keeps auto reinstalling

After I installed smartmontools by home-brew, each time I open a new zsh, it tooks half minate and then output:

Warning: smartmontools 7.1 is already installed and up-to-date
To reinstall 7.1, run `brew reinstall smartmontools`

I use brew uninstall smartmontools to uninstall smartmontools, the result showed success as following:

Uninstalling /usr/local/Cellar/smartmontools/7.1... (36 files, 1.8MB)

However, when I tried to open a new zsh, It took me tens of seconds and after that brew told me:

Updating Homebrew...
==> Downloading https://mirrors.tuna.tsinghua.edu.cn/homebrew-bottles/bottles/smartmontools-7.1.catalina.bottle.tar.gz
Already downloaded: /Users/yihan_g/Library/Caches/Homebrew/downloads/6b0e110b5ed33adadaa913ad4cc57f9d300490da9a8e30325d05d749e220f8fb--smartmontools-7.1.catalina.bottle.tar.gz
==> Pouring smartmontools-7.1.catalina.bottle.tar.gz
🍺  /usr/local/Cellar/smartmontools/7.1: 36 files, 1.8MB

It just auto update and reinstall, what should I do to uninstall it?

You seem to have the install command in your .profile or .zshrc file. If you remove it there you can uninstall normally.

Sorry, but I can not find the install command, I have no .profile, here is my .zshrc file, to save space, I deleted most commented content:

# Enable Powerlevel10k instant prompt. Should stay close to the top of ~/.zshrc.
# Initialization code that may require console input (password prompts, [y/n]
# confirmations, etc.) must go above this block; everything else may go below.
if [[ -r "${XDG_CACHE_HOME:-$HOME/.cache}/p10k-instant-prompt-${(%):-%n}.zsh" ]]; then
  source "${XDG_CACHE_HOME:-$HOME/.cache}/p10k-instant-prompt-${(%):-%n}.zsh"
fi


export ZSH="/Users/yihan_g/.oh-my-zsh"
ZSH_THEME="powerlevel10k/powerlevel10k"

plugins=(zsh-proxychains-ng git extract cp zsh_reload git-open z command-not-found safe-paste  zsh-syntax-highlighting zsh-autosuggestions)

source $ZSH/oh-my-zsh.sh

POWERLEVEL9K_MODE="awesome-patched"

# To customize prompt, run `p10k configure` or edit ~/.p10k.zsh.
[[ ! -f ~/.p10k.zsh ]] || source ~/.p10k.zsh

# Pyenv
export PYENV_ROOT="$HOME/.pyenv"
export PATH="$PYENV_ROOT/bin:$PATH"
if which pyenv > /dev/null;
  then eval "$(pyenv init -)";
fi

# Pyenv-virtualenv
if which pyenv-virtualenv-init > /dev/null;
  then eval "$(pyenv virtualenv-init -)";
fi

# The Fuck
eval 
            fuck () {
                TF_PYTHONIOENCODING=$PYTHONIOENCODING;
                export TF_SHELL=zsh;
                export TF_ALIAS=fuck;
                TF_SHELL_ALIASES=$(alias);
                export TF_SHELL_ALIASES;
                TF_HISTORY="$(fc -ln -10)";
                export TF_HISTORY;
                export PYTHONIOENCODING=utf-8;
                TF_CMD=$(
                    thefuck THEFUCK_ARGUMENT_PLACEHOLDER $@
                ) && eval $TF_CMD;
                unset TF_HISTORY;
                export PYTHONIOENCODING=$TF_PYTHONIOENCODING;
                test -n "$TF_CMD" && print -s $TF_CMD
            }
# Homebrew Bottle 
export HOMEBREW_BOTTLE_DOMAIN=https://mirrors.tuna.tsinghua.edu.cn/homebrew-bottles       

If you rename the .zshrc file to zshrc.backup (without the dot at the start) does it still run a brew command when you start the shell?

Thanks, I checked the .zshrc and .p10k.zsh, and finally I found a brew install smartmontools in .p10k.zsh, so weird, I don’t know how it just appeared there, but after all, I solved this problem, thanks