Brew doctor warns about "Warning: A newer Command Line Tools release is available"

Hi all,

This is a first for me: after upgrading to Catalina, brew doctor warns that:

Please note that these warnings are just used to help the Homebrew maintainers
with debugging if you file an issue. If everything you use Homebrew for is
working fine: please don’t worry or file an issue; just ignore this. Thanks!

Warning: A newer Command Line Tools release is available.
Update them from Software Update in System Preferences.

I must point out that Xcode’s command line tools are already installed on their latest version:

xcode-select --install
xcode-select: error: command line tools are already installed, use “Software Update” to install updates

However everything else seems to run fine (I’m using Fish but it is the same with Bash: brew update && brew upgrade && brew cask upgrade && brew cleanup && omf doctor && omf update)

I tried re-installing Brew but it’s the same.
Here’s my brew config output:

HOMEBREW_VERSION: 2.2.0-32-gfcfa80a
ORIGIN: https://github.com/Homebrew/brew
HEAD: fcfa80a63a43bb0a54d57e818044798029d338f5
Last commit: 6 hours ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: 9b2bffc776848b488e55e59a0426412529bb010f
Core tap last commit: 61 minutes ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_DEV_CMD_RUN: 1
HOMEBREW_GITHUB_API_TOKEN: set
HOMEBREW_VISUAL: emacs
CPU: quad-core 64-bit skylake
Homebrew Ruby: 2.6.3 => /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/ruby
Clang: 11.0 build 1100
Git: 2.21.0 => /Applications/Xcode.app/Contents/Developer/usr/bin/git
Curl: 7.64.1 => /usr/bin/curl
macOS: 10.15.1-x86_64
CLT: 1100.0.33.8
Xcode: 11.2.1

Maybe anyone else has stumbled upon this issue already? I’d like to get as much feedback as possible before opening a new issue.

Thanks!

2 Likes

Did you try updating from the app store?

Hi @SMillerDev!

Yep, everything is (or at least seems to be) up-to-date:

Xcode version is: 11.2.1 (11B500)
xcode-select version 2370

Xcode isn’t the same as the commandline tools per se. I’d suggest running softwareupdate --list to see if they’re disconnected

Hi there,

softwareupdate --list
Software Update Tool

Finding available software
No new software available

And the command line tools seems to be installed as well:

xcode-select --install
xcode-select: error: command line tools are already installed, use “Software Update” to install updates

Thanks!

Turns out that Apple sometimes fails to provide these via Software Update, requiring you to download them yourself.

The version of clang being looked for is 1100.0.33.12 & yours is reporting as 1100.0.33.8. Probably not that much of an issue.

❯ clang -v     
Apple clang version 11.0.0 (clang-1100.0.33.12)

Hi there, I’ve been having some trouble with this exact issue! I ran brew config to find out my Command Line Tools were not at version 11.2, so I also tried to update via the app store, via the command line, and nothing worked. Then I went to the developer website for apple and downloaded the latest non-beta for Command Line Tools, version 11.2. Instantly fixed.

4 Likes

Btw, here’s the link: https://developer.apple.com/download/more/

2 Likes

Exactly the same issue here!

1 Like

Same issue here. I wonder if Apple is aware ?

Exactly the same issue here!!