Brew doctor and xcode version

when i run brew doctor, i get the following output:

Warning: Your Xcode (11.0) is outdated.
Please update to Xcode 11.1 (or delete it).
Xcode can be updated from the App Store.

but when i examine the xcode version, i see that it does not correspond to the warning message

$ pkgutil --pkg-info=com.apple.pkg.CLTools_Executables | grep version
version: 11.2.0.0.1.1571444319

and xcode is set properly

$ ls -x1 $(xcode-select -p)
Library
SDKs
usr

how can it be fixed or is there any bug?

You’re checking the CLT tools version though. Not the Xcode version.

@SMillerDev: would you please share more than just a single sentence? :slight_smile:

It’s actually 2 sentences. If you read it again, and read your commands again you’ll notice that you don’t need more to realize that you’re wrong.

@SMillerDev: thank you for the detailed explanation. you totally helped me and others a lot!

You’re very welcome. If you have more questions don’t hesitate to ask.

@SMillerDev: will do, while hoping someone with a better attitude and much passion to share knowledge will reply. thanks again.

Try /usr/bin/xcodebuild -version to get the xcode version.

Hey,
I Know, i posted this link several times now, but consider it as a workaround for upgrading your command line tools.

The commandline tools are fine though. Homebrew is mentioning Xcode is outdated.

@y0y0z Please do not speak to @SMillerDev (or anyone on this forum) that way in future. He’s spending his free time trying to help you and not vice-versa.