Brew config show my processor as Arrandale, but my processor is Westmere-EP


(Gustavo Alvarez) #1

Hi i have a Xeon x5650 processor, wich is Westmere-EP

but brew config show it as Arrandale (mobile processors)

└───╼ brew config
HOMEBREW_VERSION: 1.3.7-2-g2225feb
ORIGIN: https://github.com/Homebrew/brew.git
HEAD: 2225febfb396f7db3ccf0c68feae6143128d9935
Last commit: 32 hours ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: d28b74beea0bfe8aad8c29b7fd5741357e9f10a1
Core tap last commit: 2 hours ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_DEV_CMD_RUN: 1
HOMEBREW_GIT_CONFIG_FILE: /usr/local/Homebrew/.git/config
CPU: 12-core 64-bit arrandale
Homebrew Ruby: 2.3.3 => /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby
Clang: 9.0 build 900
Git: 2.15.0 => /usr/local/bin/git
Curl: 7.54.0 => /usr/bin/curl
Perl: /usr/local/bin/perl => /usr/local/Cellar/perl/5.26.1/bin/perl
Python: /usr/local/opt/python/libexec/bin/python => /usr/local/Cellar/python/2.7.14/Frameworks/Python.framework/Versions/2.7/bin/python2.7
Ruby: /usr/local/bin/ruby => /usr/local/Cellar/ruby/2.4.2_1/bin/ruby
Java: 9.0.1, 1.8.0_121
macOS: 10.13.1-x86_64
Xcode: 9.1
CLT: N/A
X11: 2.7.11 => /opt/X11

how fix it?

greetings


#2

This most probably looks like a bug. The westmere CPU family is being shown as arrandale. You do have a Westmere-EP Family’s processor :slight_smile:

cc @MikeMcQuaid
Concerned files:

  1. mach/machine.h source shows 0x573B5EEC as Westmere

(Mike McQuaid) #3

What Mac do you have?


(Gustavo Alvarez) #4

is a Hackintoch

cloverized as MacPro 5,1


(Mike McQuaid) #5

We do not support Hackintoshes.


(Gustavo Alvarez) #6

i can ask why? is not the same hardware? (macpro 5,1 uses intel xeon x56xx series)


(Jacob Ledbetter) #7

Apple uses a cpu only made for macs for compatibility and size. If they were to use an Xeon, the computers would have issues with diffrent software packages and processing power.


(Gustavo Alvarez) #8

https://everymac.com/systems/apple/mac_pro/specs/mac-pro-twelve-core-2.66-mid-2010-westmere-specs.html

https://support.apple.com/kb/SP589
https://support.apple.com/kb/sp652

Mine is single socket, but the same unit