Brew and mtr 0.9.2

I just installed mtr via brew and I got version 0.9.2. I can’t find any way to install previous versions, and I can’t find any explanation of how to get this version to work without sudo. In previous versions I could chmod u+s /usr/local/sbin/mtr and then I was able to run mtr. But this does not work with version 0.9.2.

Is there way to install version 0.8.6 from brew?

Or does anyone know how to get mtr running without sudo on 0.9.2 and macOS 10.12.6?

@joshka Thanks for the link. Do you have a suggestion on how to get mtr 0.9.2 running without sudo on macOS?

I tried each of the suggested solutions and only running with sudo worked for me. Best bet would be to contact the upstream developers at https://github.com/traviscross/mtr/issues

I understand this being a security issue, but of course it’s a nuisance. Since this has not been changed yet (and I guess it never will), but I run into the same problem every time I set up a new workstation, here’s my very simple recipe:

  • sudo chown root /usr/local/Cellar/mtr/<version>/sbin/mtr-packet
  • sudo chmod u+s /usr/local/Cellar/mtr/<version>/sbin/mtr-packet

This re-owns mtr-packet to root and sets the setuid bit. Do not set the suid bit on “mtr”, it will just fail with the well-known error message.

HTH, even if this is an old thread.